"LL" TAG ON 1963 T-10 TRANS - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-22-2011, 11:24 PM
Registered User
 
Last photo:
Join Date: Feb 2011
Location: denver
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
"LL" TAG ON 1963 T-10 TRANS

Hi, I have a Chevy aluminum t10 that has some id numbers that I don't know what they mean: on the side cover has a metal tag stamped with "LL" bolted to a side cover bolt. what dose "LL" mean? second the case stamp says WG833 which what I found w= Borg Warner g= month but I found some info saying "g" along with some other letters are omitted 8= 8th day 3= 1963 3= 1,2,3 shift. so is "g" really omitted from alphabet to represent month...? FYI side cover prod date stamp= 5 2 63a, tail prod stamp 4 12 63, tail cast is t10-7d , main housing t10d-1. Any help would be great. Thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-23-2011, 08:29 AM
Registered User
 
Last photo:
Join Date: Jun 2010
Location: Syracuse, NY
Posts: 2,348
Wiki Edits: 0

Thanks: 666
Thanked 252 Times in 225 Posts
Its hard to know what someone has put in that case after 40-odd years

If you buy a rebuild kit for this trans, remember that this has the 207 maindrive (input) bearing and the input is held on with a nut.

To definitively ID this, count the teeth on the cluster gear after you open the side cover.

Heres a link to a parts diagram, it might help you
http://autogear.net/pdf/T10Catalog/T10 booklet.pdf
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-23-2011, 09:22 AM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
That link doesn't work, try this one.
http://www.autogear.net/pdf/T10Catal...%20booklet.pdf
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-23-2011, 12:41 PM
Registered User
 
Last photo:
Join Date: Jun 2010
Location: Syracuse, NY
Posts: 2,348
Wiki Edits: 0

Thanks: 666
Thanked 252 Times in 225 Posts
Sorry about that...

As far as the LL tag; I asked my boss who is an authority on the T10 and he doesn't remember an LL. It could be a builder tag, or an aftermarket gearset
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-23-2011, 08:45 PM
Registered User
 
Last photo:
Join Date: Feb 2011
Location: denver
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Hey,

Thanks for the info so far. Here are some pics that might help with my questions
Attached Thumbnails
Click image for larger version

Name:	side cover.jpg
Views:	29
Size:	5.7 KB
ID:	52965   Click image for larger version

Name:	case.jpg
Views:	27
Size:	8.3 KB
ID:	52966   Click image for larger version

Name:	tail 2.jpg
Views:	36
Size:	6.6 KB
ID:	52967  
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange thing happening with my clear "solvent pop"/"fish eyes" ? myfamiliacc Body - Exterior 35 02-16-2013 08:18 PM
1956 OLDS"98" trans swap questions gsuperdave1 Transmission - Rearend 5 10-31-2010 10:31 AM
95 GMC Safari auto trans "SLAMS" into drive rango25 Transmission - Rearend 2 03-30-2008 01:28 PM
Purchased an "OLD" GM Hydra-Matic Trans.. Bud's 27 T Touring Transmission - Rearend 1 06-02-2006 06:58 PM
Hey croz look """"IMPORTS SUCK""" 78 monte Hotrodders' Lounge 14 08-30-2002 02:13 PM


All times are GMT -6. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.