Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Hotrodding Basics (http://www.hotrodders.com/forum/hotrodding-basics/)
-   -   Lost electrical connector (http://www.hotrodders.com/forum/lost-electrical-connector-226351.html)

abbazabba 11-21-2012 06:04 PM

Lost electrical connector
 
2 Attachment(s)
I have a 98 Chevy k1500 5.7

I can't figure out what this connector goes to.

It comes off the same section as the crank position sensor and a ground strap.

Anyone have an idea?

Thanks!

seltec8 11-21-2012 06:39 PM

air pump ?

abbazabba 11-21-2012 06:49 PM

What the hell is an air pump

seltec8 11-21-2012 07:16 PM

Actually the diverter valve bolted to the air/smog pump? What are the colors?

abbazabba 11-21-2012 07:26 PM

Its a

2 pin

red with light blue boot

I will have to look at it again to get the wire colors.

abbazabba 11-21-2012 09:04 PM

Wire Color
 
Seem to be Black and Yellow

seltec8 11-21-2012 11:28 PM

I was thinking red & black.
1) Not all trucks came with an air pump if was dirty then it wasn't used.
2) There may be a coolant switch that replaced the block drain plug. (plug is at the pan rail just forward of starter end plate). a yellow or light /green color would make sense
3) It doesn't seem long enough to go to a low coolant switch in the radiator tank.
Online kinda sucks for a schematic. You can take your thank you back if you want.
Good luck


All times are GMT -6. The time now is 11:52 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.