Low Oil Pressure Sending Unit - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-14-2010, 03:11 PM
Registered User
 
Join Date: Dec 2009
Location: holland ohio
Age: 49
Posts: 67
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Low Oil Pressure Sending Unit

Just installed an early 70's small block, 010 block in my 1984 Chevy C-10. My question is on my 1984 s.b. 305 there was an sending unit I believe an low oil pressure sending unit threaded into the block by the oil filter. My 010 block does not have the provision for this sending unit. I need to know what to do with the 3 wires, Green, Blue, Tan. Cut them and cap them, or splice 2 of the wires together. This sending unit I am talking about IS NOT the oil pressure sending unit on top of the back of the block, any info would be helpful, or what this sensor is for, Thank's Ken

    Advertisement
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
low oil pressure... gearhead81 Engine 13 03-12-2009 07:54 PM
SBC low oil press but no rocker arm noise? myclone614 Engine 14 01-23-2006 05:16 PM
Found low oil pressure problem.... kc_ksom Engine 2 09-06-2005 08:01 PM
Oil Pressure Sending Unit whsipersix167 Engine 2 11-13-2004 06:59 PM
Oil Sending Unit Assistance MI2600 Engine 3 09-11-2002 08:55 AM


All times are GMT -6. The time now is 01:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.