low oil psi on sbc - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-21-2011, 08:38 PM
sweet85chevy's Avatar
Registered User
 
Last photo:
Join Date: Feb 2011
Location: canton ohio
Age: 23
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
low oil psi on sbc

ok i have a 350 with a mild cam intake and carb rebuilt it 2 years no problems with it then a couple weeks ago i started getting really bad oil psi at idle when it would warm up so i changed the oil really didnt help then i though the gauge so i got a mechanical gauge and same problem so then i pulled the pan and oil pump off took it apart and the top plate was scored from the gears so i replace the pump and the pickup and same problem still does anyone know what it is

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-21-2011, 08:51 PM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,673
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Whats it at? Colder temps require different oil weight remember.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-21-2011, 08:55 PM
406 bug's Avatar
9.82 @ 139mph
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Nov 2007
Location: phoenix, arizona
Posts: 582
Wiki Edits: 1

Thanks: 0
Thanked 1 Time in 1 Post
What is the pressure reading?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-21-2011, 08:57 PM
sweet85chevy's Avatar
Registered User
 
Last photo:
Join Date: Feb 2011
Location: canton ohio
Age: 23
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
210ish and first start up 60 to 40 warms up when drving 20 stopped at idle 0
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-21-2011, 09:49 PM
406 bug's Avatar
9.82 @ 139mph
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Nov 2007
Location: phoenix, arizona
Posts: 582
Wiki Edits: 1

Thanks: 0
Thanked 1 Time in 1 Post
Could be a number of things. most serious- bad bearings. restricted oil passage. internal oil plug leaking. New gauge bad. First I would try a heavier wt. oil and see if the pressure changes. If in fact the pressure is 0 at idle, you should not operate the vehicle. Usually on a warm engine, you should have about 10lb. pressure for every 1000rpm.

Last edited by 406 bug; 02-21-2011 at 10:01 PM.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 02-21-2011, 10:27 PM
sweet85chevy's Avatar
Registered User
 
Last photo:
Join Date: Feb 2011
Location: canton ohio
Age: 23
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
can you go too heavy on stock pump
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 02-21-2011, 10:40 PM
406 bug's Avatar
9.82 @ 139mph
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Nov 2007
Location: phoenix, arizona
Posts: 582
Wiki Edits: 1

Thanks: 0
Thanked 1 Time in 1 Post
I would not go over say 10-40. When you changed the oil did you also change the filter. If not, try a new one.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 02-21-2011, 11:14 PM
sweet85chevy's Avatar
Registered User
 
Last photo:
Join Date: Feb 2011
Location: canton ohio
Age: 23
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
yea new filter and and i have 10-30w now in it
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.