LS engine in '57 Chevy Suburban - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 02-24-2008, 11:31 AM
Registered User
Last photo:
Join Date: Feb 2008
Location: Formerly Calgary, Ab, Canada, now in France
Posts: 371
Wiki Edits: 0

Thanks: 8
Thanked 18 Times in 18 Posts
LS engine in '57 Chevy Suburban

I have a '57 Chevy Suburban with a '77 Camaro front clip. It currently has the '77 Camaro L6 in it. I am thinking about putting a EFI LS series engine in it.
Has anyone done this particular swap before? Any comment/idea is welcome.

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 02-25-2008, 02:42 AM
Registered User
Join Date: Oct 2007
Location: Bako
Posts: 172
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
my suggestion get a 5.3L truck ls motor from a later chevy truck like later than 2000 and a 4l60e trans gab a wiring harness from the truck or one from the guys at painless and you should have one nice daily driver
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Valve Lash adjustment hiball Engine 36 05-11-2009 10:12 AM
350 Chevy Issues engine trouble... Please help me! ineedspeed Engine 26 07-28-2008 04:23 AM
57 Chevy vs. 57 Pontiac fuel sending unit yenkonova General Rodding Tech 1 07-17-2004 09:59 AM
77 chevy engine temperature sensor location??? 77chevy400 Engine 4 07-09-2003 01:51 AM
Cam Help black66 Engine 3 05-12-2003 06:15 PM

All times are GMT -6. The time now is 02:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.