ls1 gto question - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 01-19-2009, 09:05 PM
Everything is HAMMER!
 
Last photo:
Join Date: Jan 2006
Location: belleville, Michigan
Age: 25
Posts: 348
Wiki Edits: 0

Thanks: 2
Thanked 1 Time in 1 Post
Quote:
Originally Posted by poncho62

I don't, but some might say that Creech's car is ruined with its tube frame, tubbed rearend and all........How could you do that to a "classic"??........
That is exactly what i was thinking.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #17 (permalink)  
Old 01-19-2009, 10:38 PM
WDCreech's Avatar
Grumpy Old Goat Herder
 
Last photo:
Join Date: Apr 2006
Location: Anchorage, Alaska
Age: 70
Posts: 1,319
Wiki Edits: 0

Thanks: 3
Thanked 29 Times in 27 Posts
Quote:
Originally Posted by poncho62
I don't, but some might say that Creech's car is ruined with its tube frame, tubbed rearend and all........How could you do that to a "classic"??........
When I found the car, for a friend, it had been wrecked. The frame was bent and the body was a mess. The friend stripped it out and raced it, and then sold it to me. I back halved it, but it still ran dog legged, thus came the tube chassis. Also this car hasn't had a title since the first time I saw it.

Reply With Quote Quick reply to this message
  #18 (permalink)  
Old 01-20-2009, 05:46 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,901
Wiki Edits: 5

Thanks: 20
Thanked 273 Times in 219 Posts
Thats fine....I was just trying to make a point. My truck was a real mess when I got it...People say to me..."Why didn't you use the flathead"...I didn't get one, the engine was missing, the front end was shot, I used what made sense to me.

I was just saying, that the GTO is his car and he shouldn't be preached to as to what he does with it.

I saw a real nice 64 Plymouth on B-J auction the other day....Hemi car.........Thing is, it is a 331 Hemi from the 50s.........Is that car ruined too?
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #19 (permalink)  
Old 01-20-2009, 09:55 PM
Registered User
 
Join Date: Jan 2009
Location: Springfield, MO
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Blazin72
Yeah, all he'd have to do is get the engine covers the late model GTO had.
well it still has the original motor in it. it is going to be a project car for me and my grandpa he has had the car for about 4 years and has done nothing with it and he is kinda getting into the whole ls motor thing
the orig plan was to put it back to stock but he has been talking a lot about puttin an ls1 in it
Reply With Quote Quick reply to this message
  #20 (permalink)  
Old 01-20-2009, 09:56 PM
Registered User
 
Join Date: Jan 2009
Location: Springfield, MO
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by poncho62
Thats fine....I was just trying to make a point. My truck was a real mess when I got it...People say to me..."Why didn't you use the flathead"...I didn't get one, the engine was missing, the front end was shot, I used what made sense to me.

I was just saying, that the GTO is his car and he shouldn't be preached to as to what he does with it.

I saw a real nice 64 Plymouth on B-J auction the other day....Hemi car.........Thing is, it is a 331 Hemi from the 50s.........Is that car ruined too?

it is she by the way
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
383 stroker 73monte Engine 11 05-07-2014 08:08 AM
supercharger.... 73monte Engine 16 07-24-2010 10:27 AM
LS1 harness question flynbrian48 Electrical 1 11-20-2007 01:25 PM
Ignotion Set-ups Native Gearhead Engine 8 11-29-2003 01:20 PM
Hi All I just Joined, Questions Re:454 rebuild Gay-Shark Engine 8 11-29-2003 10:25 AM


All times are GMT -6. The time now is 12:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.