LS1/LS2 swap into an s-10???? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-01-2007, 06:50 PM
kuhn-77's Avatar
Build it right the first time
 
Last photo:
Join Date: Jul 2006
Location: Burleson, Texas
Posts: 227
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
LS1/LS2 swap into an s-10????

A friend of mine wants to put either an LS1 or an LS2 into an s-10 chevy, has anyone here done this swap before?????

I have put a carburated 350 small block into an s-10 before, with a TH350 transmission without problems before but i dont know anything about the Fuel Injected LS-series motors or how to do the wiring involved for them?????

help plzzzzzzz

Thank you

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-01-2007, 10:27 PM
Registered User
 
Join Date: Sep 2005
Location: Mississippi
Posts: 17
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Go here

http://www.ls1tech.com/forums/
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-03-2007, 09:46 AM
Registered User
 
Join Date: Mar 2007
Location: Goose Creek, SC.
Age: 34
Posts: 16
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
There are specialized companies for wiring. I put a LT1 in my s-10 and had lt1350.com do my wiring. They took both harnesses and spliced them for a plug and play on my end, and reprogramed my pcm. As far as clearance, you might need to offset the motor to the passenger side a little to clear your steering shaft (and/or move your shaft). I also needed to notch the frame and box it in with 4X4 angle iron on the passenger side for the exhaust (weld some 3/8 plate steel on the outside of frame for extra strength). But done right it will be just as strong as factory.

Good luck,
Damian
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-03-2007, 10:09 AM
Hippie's Avatar
Analog man in a digital world.
 

Last journal entry: HEI comparison.
Last photo:
Join Date: May 2003
Posts: 2,253
Wiki Edits: 0

Thanks: 3
Thanked 5 Times in 5 Posts
Friend of mine just put an LS-1 in a 2000 something Blazer Xtreme 2WD. Cool as Hell but man what a job! He bought a wiring harness and headers off some guy on the internet that were supposed to be plug n play. He spent all winter rewiring it correctly and had to have the headers cut apart and redone by a local shop. It is a TIGHT fit!
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-31-2011, 08:27 PM
Registered User
 
Join Date: Jul 2011
Location: Lawrence, Kansas
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
There is a company in Florida called Current Performance Wiring. The owners name is Jarrod, 1-727-844-7570. He does wiring harnises for S-10's and use to do complete makover on S-10. He has alot of products and alot of information. He builds a long tube header for S-10. 1 5/8 tubes and 3 in collectors, they are great. Give him a call, he will talk to you. He has a business to run so do not tie him up all day.
A friend of mine used Jarrod to help him put a LT-1 in and S-10.

Good Luck,

Junkyard
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cam swap Questions wayfast77 Engine 3 10-18-2006 05:52 AM
F-body differentials, 9 bolt Borg Warner vs. GM 10 bolt Mad Maggot Transmission - Rearend 8 02-17-2005 09:02 PM
Swap meet score Bluepen Hotrodders' Lounge 5 10-07-2004 09:49 AM
Engine Vacuum is showing 10 and no higher? ataririder Engine 42 02-18-2003 08:12 PM
40 ply/s 10 clip gcorbit Suspension - Brakes - Steering 0 01-28-2002 04:53 PM


All times are GMT -6. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.