LT-1 having problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-30-2007, 11:35 AM
Registered User
 
Join Date: Nov 2007
Location: Denver, Co.
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
LT-1 having problems

I have a 1994 caprice classic ls with the LT-1 5.7L, and the problem is the car runs like crap when it first starts. Then when it warms up the engine stats to run fine but, the elec. fan stays running intill car is shut off.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-30-2007, 12:05 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: Seattle, Wa
Posts: 6,754
Wiki Edits: 0

Thanks: 4
Thanked 419 Times in 361 Posts
Quote:
Originally Posted by todd77
I have a 1994 caprice classic ls with the LT-1 5.7L, and the problem is the car runs like crap when it first starts. Then when it warms up the engine stats to run fine but, the elec. fan stays running intill car is shut off.
Sounds like the dedicated (to the computer) engine temp sensor is failing. My take on the symptoms is it's telling the computer the engine is not only warm but perhaps overheating. In the first instance, the engine doesn't receive cold start fuel enrichment so it runs crummy till it warms up to where the F/R is correct for the actual temp. The second instance is that the computer thinks the engine is always hot so it switches the fan on and holds it no matter what the real world is doing.

Bogie
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-30-2007, 01:02 PM
Registered User
 
Join Date: Nov 2007
Location: Denver, Co.
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
re

Thanks, before this started the car would cut out bad so then i put a fuel pump in it hopeing that would fix it and it did'nt. Then i put a new distributor form summit raceing after i did that thats when this started to do what it is doing now.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Olds 98 Ignition Module Problems awbazar Electrical 1 01-12-2004 06:42 AM
beater car problems 02 0n 20s Engine 2 11-01-2003 06:53 PM
Light Problems like crazy ponybuster Electrical 7 10-14-2003 12:12 PM
I Hate Electrical Problems! tm454 Hotrodders' Lounge 20 09-28-2003 07:40 AM
corvette LT 1 arborlis Engine 2 04-24-2003 04:35 PM


All times are GMT -6. The time now is 02:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.