LT! Wiring Harness - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-16-2003, 09:17 PM
New Member
 
Join Date: Aug 2003
Posts: 29
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
LT! Wiring Harness

Does anyone know a company that reworks a stock harness for a retro fit for a rod? The after market one's sure are high priced?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-17-2003, 12:14 PM
EBlack36's Avatar
Rebuilt Excitment
 
Last photo:
Join Date: Aug 2002
Location: Lansing, Ks
Age: 62
Posts: 595
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
http://www.lt1350.com/

I have not used these people. Also do a search on Google and a number of sites show up.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-24-2003, 10:54 PM
New Member
 
Join Date: Sep 2003
Location: north carolina
Age: 33
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I don't know any that rework however I am sure that painless wiring makes a harness but i am not sure of the price .
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-02-2003, 09:00 PM
New Member
 
Join Date: Nov 2002
Location: texas
Posts: 28
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
lt1 harness

For comparision, we charge right around a grand to rework harnesses, and 650.00 for new, custom-configured units. If you or a buddy are proficient in rewiring efi harnesses, we do sell power centers, parts and such, that you will need to do it yourself, at a fraction of the cost. If you are buying, it's absolutely cheaper and more reliable to buy new. To add to the confusion, properly programming the pcm, or chip is also necessary, for many more reasons than just deleting the security system, which will not allow the engine to remain running. Hope this helps.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.