Lt1 - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> Introduce Yourself
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 08-29-2006, 07:59 PM
Registered User
Last photo:
Join Date: Aug 2006
Location: Odenville AL.
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts

I need any information of troubles with sensors on LT1. Making car to run sluggish.

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 08-29-2006, 08:08 PM
Henry Highrise's Avatar
Lost in the 60's
Last wiki edit: Removing stuck fasteners Last photo:
Join Date: Dec 2001
Location: Dixieland
Age: 70
Posts: 15,189
Wiki Edits: 4

Thanks: 0
Thanked 12 Times in 11 Posts to post that question over in the Electrical forum I think.....It would be seen more...this is the Introduction forum.
Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
might switch my 383 for LT1? 68Loper75 Engine 7 10-24-2010 07:33 AM
lt1 cop car Brian Morency Engine 27 08-24-2006 03:38 PM
LT1 Motor Mounts Brian Hix Engine 0 09-17-2003 08:42 PM
94 Camaro lt1 Vs. 95 Camaro lt1 NEEDHELP Engine 3 11-05-2002 11:45 AM
Need LT1, or LS1 Sycotic Engine 0 09-17-2002 07:36 PM

All times are GMT -6. The time now is 07:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.