LT1 Z/28 ingtion modlue - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-27-2010, 07:21 AM
rachet ralph's Avatar
Registered User
 
Last photo:
Join Date: May 2008
Location: cliftonpark, new york
Age: 54
Posts: 147
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
LT1 Z/28 ingtion modlue

i just got a 1995 Z/28 with a LT1 an guy thought needed a opti spark dist. but day i got it home it started! but when engine got to running temp it cut off an had no spark from coil! but doing system check has pluse from opti spark dirt. so i feel not dist! an it's ingtion modlue but the dam thing $185.00 am local salvage yards want $75.00 to $80.00 for it, an being electric part there as is! so has anyone ever tried to use a module from early type HEI with vacum advance, being there both a 4 wire system, i have schematic for the opti spark system, anyone have one from early HEI see if maybe can wire an early type in as i feel both get there pluse from dist. an has anyone ever tried this?
Attached Thumbnails
Click image for larger version

Name:	95_ign_system_schematic.jpg
Views:	123
Size:	64.2 KB
ID:	46985   Click image for larger version

Name:	3n43p43la5Y35W45R5a6s75cb927827991114.jpg
Views:	92
Size:	7.8 KB
ID:	46986   Click image for larger version

Name:	3na3k43p45T45Q15W4a6sb2263d245c7b101d.jpg
Views:	90
Size:	6.4 KB
ID:	46987  

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-08-2010, 08:05 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,340
Wiki Edits: 0

Thanks: 222
Thanked 276 Times in 256 Posts
some of the newer s 10 pickups use a module that will plug in but I dont think I would go that route better to go to GM and buy a good one. A lot of aftermarket stuff in electronic parts are inferior and dont last if they even work. How much is your time worth.car looks pretty nice.If it were mine I would buy the new gm part if you are sure.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-12-2010, 10:10 AM
S10 Racer's Avatar
http://www.warsprints.com
 

Last journal entry: W.A.R. (Wingless Auto Racing) Sprint Car Racing
Last photo:
Join Date: Nov 2007
Location: At The Dirt Tracks
Age: 55
Posts: 1,927
Wiki Edits: 0

Thanks: 4
Thanked 70 Times in 63 Posts
Quote:
Originally Posted by rachet ralph
i just got a 1995 Z/28 with a LT1 an guy thought needed a opti spark dist. but day i got it home it started! but when engine got to running temp it cut off an had no spark from coil! but doing system check has pluse from opti spark dirt. so i feel not dist! an it's ingtion modlue but the dam thing $185.00 am local salvage yards want $75.00 to $80.00 for it, an being electric part there as is! so has anyone ever tried to use a module from early type HEI with vacum advance, being there both a 4 wire system, i have schematic for the opti spark system, anyone have one from early HEI see if maybe can wire an early type in as i feel both get there pluse from dist. an has anyone ever tried this?
One thing to look for. I had a 95 caddy and had a tune up done at a local garage. They changed the plugs, coil & cap. It ran good going home (about 12 miles) and died in the driveway. I called them and they came out and replaced the ignition module. Ran fine for about a day. Burnt the ignition module out again. This happened 3 times, almost to the point that the auto parts store was not going to keep replacing the module. I decided something else was wrong. After removing the coil cover I found that when the garage replaced the coil, they did not re-install the grounding strap from the wire harness to the coil base. After I fixed that, it ran great with no more problems until the wife hit two deer with it and totalled it out.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
might switch my 383 for LT1? 68Loper75 Engine 7 10-24-2010 08:33 AM
LT1 Z/28 no spark rachet ralph Engine 10 07-06-2010 09:10 PM
LT1 Swap in 71 Chevelle 71haulnazz Engine 2 06-07-2010 08:03 AM
Lt1 heads on vortec block Ugly89Camaro Engine 3 01-14-2008 10:53 PM
94 Camaro lt1 Vs. 95 Camaro lt1 NEEDHELP Engine 3 11-05-2002 12:45 PM


All times are GMT -6. The time now is 08:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.