Major C6 Issues - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-29-2004, 01:27 PM
BigBlockBabe's Avatar
Missing You
 
Last photo:
Join Date: Jul 2002
Location: Marietta, GA
Age: 36
Posts: 300
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Major C6 Issues

Ok, here's the rundown for anyone who hasn't heard me talking about the Bronco for the last 3 years. 1978 Bronco, 429/C6.

(Sorry this is lengthy, I feel you need the whole story on how the tranny has been acting)

My dad is having issues with the C6. Ok, when we first fired up the 429, and drove it, the 1-2 shift was too soft? If you laid into the throttle and got the R's up, it wouldn't shift until you let off. Even shifting manually you could feel something wrong. My dad and brother decide its not got enough modulation (or maybe he said too much modulation?) so dad buys a B&M shift kit. Get that in, and drive it and right out of the driveway its like boomboom and its in 3rd. It ran right through 1st and 2nd gears. Not good.

Oh and when he pulled the valve body out the first time, the fluid was pink like strawberry milk. He said it might have gotten water in it from sitting 3 years in the truck - he did have plastic covering the input? shaft.

He pulls the valve body out to see if maybe he left a check ball out or something, puts it back in (he may have left out the shift kit and made it normal again, I don't know) but drive it again and it feels like 2nd gear is slipping and the shifting is still not right. I talk to my brother and he said that he got the feeling that dad pieced the C6 together with parts from 2 transmissions. So I borrowed a book from a friend of mine that has all the pressures and stuff so dad can check the tranny.

Dad thought the valve body was just messed up, and got the valve body out of another C6 and when he checked the pressures everything was great, we were all fired up because he thought he'd found the problem and that he wasn't gonna have to pull the tranny out.

There's no reverse now. None. You can put it in reverse and at idle it kinda rolls back, but you rev it up, and nothing, sounds like its in neutral. Reverse was fine before and the forward gears were messed up. Now the forward gears have good pressure, but reverse is not there.

(Oh and I have no idea if this has any bearing on the problem, but dad said he almost put too much cam in it, like it doesn't have enough vacuum.)


Well? Any ideas? My dad is totally stumped on this one. Too bad we can't somehow fab a 727 in it, he can build the crap out of some Dodge trannies.


(And I don't know if this has anything to do with it or not, but could the transfer case somehow mess with how the tranny is acting?)

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-29-2004, 01:56 PM
badknuckles's Avatar
you talkin to me?
 
Join Date: Nov 2003
Location: fort lewis, wa
Age: 33
Posts: 1,090
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
if it is shifting fine now and you have no reverse i would say you got another bad valve body.
or its time for a rebuild.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-29-2004, 02:23 PM
M&M CUSTOM's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Transmission identification
Last journal entry: 1988 Suburban, the project continues.
Last photo:
Join Date: Mar 2003
Location: Northwest Pennsylvania.
Age: 42
Posts: 2,230
Wiki Edits: 9

Thanks: 0
Thanked 1 Time in 1 Post
Re: Major C6 Issues

Quote:
(Oh and I have no idea if this has any bearing on the problem, but dad said he almost put too much cam in it, like it doesn't have enough vacuum.)


Well? Any ideas? My dad is totally stumped on this one. Too bad we can't somehow fab a 727 in it, he can build the crap out of some Dodge trannies.


(And I don't know if this has anything to do with it or not, but could the transfer case somehow mess with how the tranny is acting?)
The vacuum (or lack there of) can have a major playing role on the upshift action, but would have no effect on reverse.

If he can build a Dodge tranny he only needs the right parts and a book for the C6, he should breeze through that one too.

The transfer case would have no effect at all on how the transmission is acting, you either have a 203 or a 205 t-case, and it only relies on the output of the transmission, and the position of the shifter.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-29-2004, 05:47 PM
airworld2's Avatar
Member
 
Last photo:
Join Date: Mar 2003
Location: houston texas
Posts: 583
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
c6 trouble

no reverse , wrong year valve body ????? could also be stuck 2-3 shift valve....
water in the tranny fluid is trouble, damage will be imminent
__________________
airworld2
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.