Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Electrical (http://www.hotrodders.com/forum/electrical/)
-   -   Mallory HEI distributor (http://www.hotrodders.com/forum/mallory-hei-distributor-34463.html)

overlap 02-18-2004 04:18 PM

Mallory HEI distributor
 
I recently purchased a Mallory HEI dis. model# 8548201c. I got it to replace my stock distributor on my '84 Ponitac Grand Prix , Chevy 305. I have a Holly Carb and was told I would need a earlier style dis. I called summit and they recommended this distributor cause I wanted to stay HEI. I knew that the connection to the ECS would be lost and I kinda wanted it to. Let me get to the point, I removed the old distributor making sure the rotor was pointing at the num. 1 spot and I removed it. The rotor spun during removal but it had to in order to release. I tried placing the mallory so that the rotor would be lined up the same facing num.1 ( the line I drew on the manifold) , but it wouldn't mesh so I spun the rotor until it meshed perfectly down into the block. I wired everything I could back up, but it wouldn't start. I was told after asking around that maybe I "180 out". Not sure what that meant but I decided to move the wires around on the cap keeping the same firing sequence 1,8,4,3,6,5,7,2. I just rotated them to different spots on the cap. It originally looked like this on the cap:

............................................6...5
.........................................3........ .7
.........................................4........ .2
............................................8...1
But the only way it would start is when I moved the #1 wire to the 2 spot and everything sequenctially (2 to 7, 7 to 5,... 8 to 1) . It started but wasn't working right had no power. I didn't change the sequence just the spots on the cap. I'm really not sure what I'm doing wrong so any help would really make my day. And if you need any more info I'll tell you whatever I can.

Thanks

Mista_T 02-19-2004 05:22 PM

It seems to me like you just need to start from scratch. This link will step you through it: http://73-87.com/7387garage/drivetrain/disremov.htm

Good luck.

overlap 02-19-2004 06:17 PM

Well I got some it solved. I found TDC and from another forum I was told how to get it so the new dist. lined up the way i'm use to. I put back in the old dist. and it worked fine, but when I put the Mallory back in the car was still real sluggish. Now is this a power issue? Someone told me it might be. I assume the stock plug to the HEI coil is 12V. The other thing is that the stock distributor plugs into the computer, but the mallory doesn't nor do I want it to. I don't think this has anything to do with it but I could be wrong. I also have an MSD 6A ignition box , now if I installed that would it help or just be in not solving the problem? Any help is appreciated.

Thanks

dmorris1200 02-20-2004 05:07 AM

Just a couple of quick questions. You never mentioned in either post what you are setting your timing at. The first step after installing any distributor is checking timing. Also since I'm short for time and don't know the Mallory numbers you posted, is your Mallory vacuum advance? Is the Mallory you're installing designed to run without an ignition box or computer? If it is a self-contained unit that requires no external box or computer it should work with an after-market Holley carb.

http://hotrodders.com/photos/0000145..._121992289.gif

overlap 02-20-2004 07:27 AM

The mallory is vacuum advanced. It is designed to run by itself. WHen I put it in I set it to 0 degree and it started but was real sluggish and died. then I set it 10 degree advance thats when It sounded fine but had no power.

dmorris1200 02-20-2004 07:45 PM

I would try advancing your base timing two degrees at a time (12, 14, etc.) and see how she responds. Also make sure you have a good signal to the vacuum advance and she is advancing properly. Most Mallory distributors come with adjustable vacuum advance cans. There is a screw that adjusts with an allen key through the nipple hole (where the vacuum hose goes) which adjusts your vacuum advance. I don't remember where my directions are for adjusting the vacuum advance but I'm sure Mallory's tech line could help. You may need to experiment a little bit with both ignition and carb adjustments. My base timing is set at 15* BTDC and I tweaked my vacuum advance to give me more advance under part throttle. Every engine is different as far as how much advance they need. Last but not least I assume you are setting base timing with the vacuum hose to the advance disconnected and the hose plugged.


http://hotrodders.com/photos/0000145..._121992289.gif


All times are GMT -6. The time now is 02:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.