Mallory Ignition trouble - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-06-2009, 03:33 PM
66Moostang's Avatar
Registered User
 
Join Date: May 2008
Location: Las Vegas
Posts: 33
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Mallory Ignition trouble

On my Ford 302 in my '67 Cougar i have a Mallory electronic ignition and it worked great when i got the car and now sometimes it just stalls out of no where. But it starts right up again every time. A friend of mine said it definitely sounded like an ignition problem but i have no experience with any Mallory products or even any electronic ignition setups.

When it runs it runs strong. The rebuilt engine only has 10k miles and i drove it everywhere for a while. I just need to figure out whats going on here.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-06-2009, 03:44 PM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 47
Posts: 8,908
Wiki Edits: 0

Thanks: 19
Thanked 363 Times in 333 Posts
What Mallory ignition is it, they make several different types -- points, breakerless electronic, or capacitive discharge??
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-06-2009, 03:44 PM
wildthing's Avatar
Registered User
 

Last journal entry: time flies
Last photo:
Join Date: Jun 2007
Location: chambersburg, pa.
Posts: 223
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
humm , i have a 68 cougar with a 302 .
ahh does it stall or shut off ? if it stalls , i would think fuel problem , like clogged filter. if it shuts off like a switch is turned then electrical. could be just a bad connect. the wireing in our cars is getting pretty old.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-06-2009, 03:49 PM
66Moostang's Avatar
Registered User
 
Join Date: May 2008
Location: Las Vegas
Posts: 33
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
i dont know what mallory it is.. i have a mallory coil and a mallory distributor.. i should..

sometimes it wont start up after it shuts off.. it isnt stalling.. its shutting off.. if it wont start up then i disconnect the battery cable then connect it again and it fires right up when i turn the key
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Color codes for 2002 S10 Ignition switch tommer2 Electrical 1 10-22-2008 06:16 PM
Fried wire from ignition to soleniod? frankenvette Electrical 4 07-31-2008 02:45 PM
Ignition - No Spark DaytonaCoupe Electrical 3 07-04-2008 10:28 PM
MSD Vs. Mallory 71 c-10 Engine 6 01-07-2008 08:58 PM
ignition circuits jjpodlas Electrical 2 11-26-2007 10:41 AM


All times are GMT -6. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.