Martins turbo system - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-01-2011, 08:35 PM
Registered User
 
Join Date: Nov 2011
Location: Bonduel, WI
Posts: 9
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Martins turbo system

Hi my names Beau. I have a 400 sbc with a Martins turbo system in a 71 Monte Carlo. I have some questions about it. First off is there any way to adjust the boost? When I rev the engine up the boost gauge stays in the vacuum part of the gauge, doesn't actually build boost. Do i need to have a load on the engine to make it produce boost? And how much boost can i run on a stock engine? Thank you.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-02-2011, 09:07 PM
Member
 
Last photo:
Join Date: Oct 2004
Location: IL
Age: 47
Posts: 238
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
If you put 70 Monte Carlo Turbosonic on you tube you can see my car. It has a drawthrough sytem very imilar to the Martin kit. I put a bleed valve on mine that got the boost up to 10 from 7. Back in highschool a freind of mine had Martin kit that would see 15psi. To anser your question, yes the turbo needs load to build boost. FYI the kit worked great for me, no horror stories about hardstarts or firebomb backfires. If anything my car was too modified with a 3.90 gear and 3500 stall( it was a tempory engine). Ideally, you would want to slap these kits on a stock car with 3.08 gears, just like they were designed for. My 350 wuld hit a brick wall at 5000 rpm, even with a 350hp cam and upgraded valvesprings. Your 400 will probaly stop pulling at 4500-4800 rpm. That's why you don't want steep gears with these kits. The answer would be to install a wastegate on the exhaust. It was a fun kit, drove like stock until you put your foot in it!
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-06-2011, 08:18 PM
Registered User
 
Join Date: Nov 2011
Location: Bonduel, WI
Posts: 9
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Martins turbo system

The engine I have in it is a bone stock 400 with a 468 lift cam not sure of the duration. The transmission is a tb350 with a good shift kit and I put a 4000 stall converter. When I get on it the boost gauge only goes up to zero. At first I thought I had too big of a converter in it so I put a stock converter in just today. Took it for a ride and the gauge still goes to zero, which is giving me reason to believe the turbo isn't even working and the car just doesn't have any pull. How can I really tell if the turbo is working or not.
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intercooler for Twin Turbo System TrentonHuber Engine 7 04-17-2009 12:07 PM
Turbo System Gearstix Engine 8 01-02-2009 08:24 PM
Kind of a followup to Martins water heater thread Kevin45 Off-Topic 9 03-26-2008 02:08 PM
Hello I have a nova w/sbc w/ a ray jay turbo system Austin408 Introduce Yourself 1 11-09-2007 07:45 PM
turbo system fred56 Engine 8 12-14-2003 11:41 AM


All times are GMT -6. The time now is 03:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.