Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   Master cyinder losing fluid from cover (http://www.hotrodders.com/forum/master-cyinder-losing-fluid-cover-200028.html)

Fat 48 06-08-2011 12:23 PM

Master cyinder losing fluid from cover
 
I have a disc/drum set-up, 7" booster with 82 Corvette master cylinder. I replaced both rear wheel cylinders and now have brake fluid leaking past the gasket between the lid and the body of the M/C when the car is driven. It was not leaking before I replaced the wheel cylinders. The system also has a prportioning valve which I suspect may somehow be the culprit. Any suggestions on what to check would be appreciated.

adantessr 06-08-2011 12:39 PM

You would have to have a bad gasket on the cover for it to leak . The rubber gasket has sort of a diaphram function to allow for expansion of the brake fluid. Make sure that it is installed correctly. If the gasket is good and installed correctly, theoretically, you could turn the master cylinder upside down and not leak any fluid.

Fat 48 06-08-2011 12:48 PM

Thanks. I tried a new lid and gasket but it's still leaking.

crownver 06-08-2011 01:42 PM

Is the cover bail tight enough? Maybe a nick in the sealing surface of the master cyl.?

Fat 48 06-08-2011 01:48 PM

The cover fits tight. I think the key clue here is that there was no leak prior to replacing the wheel cylinders, so the leak is perhaps due to something I did while bleeding the system, or something I failed to do. Is it possible that replacing the wheel cylinders tripped something in the proportioning valve that's causing a pressure build up in the M/C to force fluid past the gasket whenever I depress the brake pedal? Or if the fluid level in the M/C dropped too low would failing to bench bleed the M/C cause this problem?

joe_padavano 06-08-2011 02:39 PM

How old is the M/C? Does the fluid in the other reservoir go down? I had a problem once where one reservoir of my M/C would fill up and overflow like yours, but over time the other side lost fluid. There were no external leaks. I finally figured out that the internal seals in the M/C were worn and fluid was being pumped from one circuit to the other. A new M/C fixed the problem. I think you may have disturbed the old seals in the M/C when you bled the brakes.

It is also possible that the seals in the combo valve are bad, allowing a similar transfer of fluid, but my money is on the M/C. Those are the only two places in the brake system where fluid from one circuit can flow into the other circuit if there's a bad seal.

T-bucket23 06-08-2011 09:39 PM

You may have hurt the master while bleeding for the new cylinders. As joe stated in the previous post fluid may be leaking between the front and rear reservoirs. Try taking some fluid out of bot so they are down a quarter inch or so. Drive it and see if one side fills back up.

Fat 48 06-10-2011 07:03 PM

I dropped the fluid level but it still overflows. I had a friend depress the brake pedal while I watched the master cylinder with the lid off and it was like Old Faithful! Brake fluid was shooting up out of both reservoirs. Is that normal? Still not clear to me how it's getting past the gasket. I guess I'll try a new M/C and see if that clears it up.

joe_padavano 06-11-2011 08:15 AM

Quote:

Originally Posted by Fat 48
I dropped the fluid level but it still overflows. I had a friend depress the brake pedal while I watched the master cylinder with the lid off and it was like Old Faithful! Brake fluid was shooting up out of both reservoirs. Is that normal? Still not clear to me how it's getting past the gasket. I guess I'll try a new M/C and see if that clears it up.

Let's ask the question again. You dropped the fluid level. When it started to overflow, was the level HIGHER than when you started? Was it in both reservoirs or just one? Was the other one lower than when you started?

Fat 48 06-11-2011 11:34 AM

I dropped the fluid level in both reservoirs. Every time it overflowed, I took the lid off and both reservoirs were approximately at the same level as before and it did not appear as though one reservoir was gaining fluid at the expense of the other.

Fat 48 06-17-2011 12:58 PM

I replaced the master cylinder and so far there's been no more fluid overflowing from the rear reservoir. Thanks to all for their comments and suggestions!

adantessr 06-17-2011 03:51 PM

Quote:

Originally Posted by Fat 48
I replaced the master cylinder and so far there's been no more fluid overflowing from the rear reservoir. Thanks to all for their comments and suggestions!

Glad you got it fixed. :-)


All times are GMT -6. The time now is 02:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.