Maybe torque converter gone bad? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-01-2004, 07:28 PM
Grumpy
 
Last photo:
Join Date: Dec 2002
Location: D.C.
Posts: 1,447
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Maybe torque converter gone bad?

Got another buick here and when I step on the gas in drive the car just creeps along until it finaly picks up speed, but its not a sudden pick-up, its more of a smooth-slow pickup.

It's odd, because The engines RPM doesnt seem to affect it much. Example, if I just lightly step on the gas, the car will creep up to speed, but if I put a little more gas into it, the RPMs go up, but the speed increase is still the same. Sometimes it feels like it doesnt stall until 3000RPM or so. The transmission goes through all 4 forward gears fine, it's just getting the thing up to those higher speeds.

So what do ya think it sounds like? Torque converter? The factory stall is around 2000, so something is not right.

Thanks.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-01-2004, 11:44 PM
Member
 
Join Date: Aug 2003
Location: calgary canada
Posts: 727
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Sounds like a possible owc failure in the torque converter.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-02-2004, 12:16 AM
Grumpy
 
Last photo:
Join Date: Dec 2002
Location: D.C.
Posts: 1,447
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the reply.

Yeah something just doesnt seem right with it, driving it some more and the trans shifts fine from gear to gear, but the fact I can put my foot down on the pedal and watch the RPMs go up, but only accelerate slowly, its a weird feeling. Especially when I go and put my foot down lightly and it accelerates at the same pace as when I mash it. Strange feeling.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-02-2004, 06:35 AM
TurboS10's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Auto Terms and Definitions Used in Modern Engine T... Last photo:
Join Date: Sep 2002
Location: Texas
Age: 37
Posts: 3,463
Wiki Edits: 2

Thanks: 0
Thanked 0 Times in 0 Posts
Stupid question perhaps, but have you checked the fluid level. My TH350 developed a leak while setting parked on a hill out the tail shaft once. It did the same thing, but was because of obvious oil level problems. Luckily I checked it and found the problem.

Chris
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-03-2004, 08:39 AM
Grumpy
 
Last photo:
Join Date: Dec 2002
Location: D.C.
Posts: 1,447
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yeah, I checked the level and it was fine, kind of a dark red though(like blackish red). Gonna change the O-ring, filter and fluid in a day or two, see if it helps at all.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 06-03-2004, 06:52 PM
BstMech's Avatar
NYOFP4RJ3CHRIS
 
Join Date: Sep 2002
Location: TN. In the corporate states of America
Age: 41
Posts: 1,552
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally posted by Robinson Robin
Sounds like a possible owc failure in the torque converter.
Is that a new acronym for a stator clutch?

What will they think of next........

I wouldn't doubt that the clutch is fine, but the stator itself is chunked up.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 06-03-2004, 08:46 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,097
Wiki Edits: 1659

Thanks: 340
Thanked 102 Times in 98 Posts
Cool

I kinda thought he meant ORC ............Over Run Clutch in the stator of the converter



__________________
I gotta sign this too?

Tony
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.