Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Mazda 626 Transmission problems
View Single Post
  #3 (permalink)  
Old 03-19-2012, 06:07 AM
cobalt327's Avatar
cobalt327 cobalt327 is offline
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 60
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 598 Times in 547 Posts
Quote:
Originally Posted by Toddclary
Hi so i haven't posted anything in a long time and honestly this is about a daily driver of mine not a hotrod. I came here because you guys are very knowledgeable and have helped me out a whole lot in the past so i figured id give it a shot and see what happens.

I drive a little 4cylinder Mazda 626 during the week because its cheap on gas and really helps me out since I'm driving a lot for college and don't work all that much.
This car has a G4A-EL type transmission in it. Just recently it started staying in second gear.. Like the car will shift from first to second and then stay in second gear until about 55 mph at about 5.5k rpms and thats where i stop pushing it hoping maybe it will switch gears.. I can put the car into second gear manually and then push it up into drive and it still will not switch gears.. Sometimes when it goes to switch from first to second gear it just rev's up really high and doesn't catch second until i let it rev back down and finally switches.. Ive just recently replace the transmission filter hoping for some change and it did not help at all. Any advice?
Had occasion to work on same trans, had a no shift into second gear until the engine and trans was hot.

Rebuilt trans and same problem, found a sticking valve in VB to be the culprit.
Reply With Quote