Hot Rod Forum : Hotrodders Bulletin Board - View Profile: jaw22w
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board
User Name
Password
lost password?   |   register now

jaw22w jaw22w is online now

Registered User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. woodz428
    07-09-2014 01:00 PM - permalink
    woodz428
    I saw your post on the glow issue. Although most of the responders on the thread felt like you have a good ground..I'm not so sure. It definitely has the smell of a bad ground in the system. While there was much exchange regarding the grounding of the dash, I have to wonder about ground directly from the battery. If the dash ground is connected to the engine and there isn't a ground to the frame, it may not be getting a proper ground because of the rubber in the mounts. If the battery is grounded to the frame and there is not a separate ground to the body (or engine if the dash is grounded to it) from the frame, any grounding is impaired to the body/dash. Just a sugggestion.
    Woodsy

About Me

  • About jaw22w
    Location
    Indiana
    Interests
    hot rods, race cars, and coins
    Occupation
    retired

Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: Today 11:38 AM
  • Join Date: 10-12-2011

All times are GMT -6. The time now is 12:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.