million dollar c4 question - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-26-2009, 09:05 PM
Registered User
 
Join Date: Nov 2006
Location: Delta BC Canada
Posts: 49
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
million dollar c4 question

Long story, I have a 69 Mustang that I have owned since 1979. Back in 80 I blew the tranny and picked 1 up from a wrecker. Bolted in fine and worked except that the inspection plate from the original c4 does not fit. Started a rebuild back in 82, kids came along and the project sat in the garage for almost 30 years. Now the kids are gone and damned if I'm going to watch Oprah with the old lady. Soooo I've been chipping away at the old Stang and I had the tranny rebuilt with a shift kit and higher stall converter.Sorry to bore you all but I was wondering if there are different bell housings for a c4? I have a 302, and as I said this tranny worked but the inspection plate bolt pattern is 1/4 inch wider than what was on there before and one of the dogs ,backplate -tranny doesn't quite line up. Any experts out there? Thanks in advance.

    Advertisement

Last edited by zuker60; 02-26-2009 at 09:11 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-27-2009, 12:19 AM
aka Duke of URL
 
Last wiki edit: Finding vacuum leaks Last photo:
Join Date: Oct 2001
Location: Rockville, MD
Posts: 4,821
Wiki Edits: 1

Thanks: 0
Thanked 0 Times in 0 Posts
The C4 went through a redesign in 1970. You may have lucked out and got a later model. Any Assembly I.D. Tag Nos.?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-27-2009, 03:07 AM
Registered User
 
Last wiki edit: Transmission identification
Join Date: Mar 2008
Location: Terra
Posts: 678
Wiki Edits: 85

Thanks: 0
Thanked 22 Times in 20 Posts
Quote:
Originally Posted by zuker60
Long story, I have a 69 Mustang that I have owned since 1979. Back in 80 I blew the tranny and picked 1 up from a wrecker. Bolted in fine and worked except that the inspection plate from the original c4 does not fit. Started a rebuild back in 82, kids came along and the project sat in the garage for almost 30 years. Now the kids are gone and damned if I'm going to watch Oprah with the old lady. Soooo I've been chipping away at the old Stang and I had the tranny rebuilt with a shift kit and higher stall converter.Sorry to bore you all but I was wondering if there are different bell housings for a c4? I have a 302, and as I said this tranny worked but the inspection plate bolt pattern is 1/4 inch wider than what was on there before and one of the dogs ,backplate -tranny doesn't quite line up. Any experts out there? Thanks in advance.
If the one from the wrecker bolted in, I don't see how you could have the issue you have with the cover. There was only one 302 bell housing on C4s in 1969 for case fill C4s behind 302s. Using any other bell housing would have meant flexplate problems and/or block plate problems and/or converter problems and/or mounting problems and/or clearance problems. Since you said it bolted right in, I assume that you had none of those problems. So, the only other alternative I can think of is that the plate you have was from something else and got mixed up sometime in the last 39 years.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-27-2009, 07:09 AM
Registered User
 
Join Date: Nov 2006
Location: Delta BC Canada
Posts: 49
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
No id tag ,already looked for one. Got the cover plate off of Ebay because I couldn't find the one that I had. Cover plate that I had off of the original posed the same problem I recall. I'll check to see if a later cover plate will work, thanks guys.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
383 stroker 73monte Engine 11 05-07-2014 08:08 AM
supercharger.... 73monte Engine 16 07-24-2010 10:27 AM
C4 install question demitristewart Transmission - Rearend 4 09-20-2005 09:27 AM
Ignotion Set-ups Native Gearhead Engine 8 11-29-2003 01:20 PM
Hi All I just Joined, Questions Re:454 rebuild Gay-Shark Engine 8 11-29-2003 10:25 AM


All times are GMT -6. The time now is 08:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.