motor locked after installing c4 trans - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-31-2013, 05:05 PM
Registered User
 
Join Date: Jan 2013
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
motor locked after installing c4 trans

hi guys ive just installed a c4 trans to 351clevo tryed to start but no crank no start chacked connections looked ok ,took out plugs tryed to turn by hand woodnt budge, wandering ifin i can get some good advise as im no mechanic ,any help much aprciated cheers.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-31-2013, 05:18 PM
Registered User
 
Join Date: Nov 2011
Location: pennsylvania
Posts: 110
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
motor locked up

sounds as though front pump and torque converter are not aligned.unbolt torque converter from flex plate and see if you can move converter toward transmission,also try to rotate engine. could have damaged front pump if they werent aligned.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-31-2013, 07:09 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Morris update 9-28-2014
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,173
Wiki Edits: 1659

Thanks: 405
Thanked 106 Times in 102 Posts
Can not rotate converter on C4 application, although there should be movement as mentioned. Converter studs protrude thru the flexplate during install.

Is it possible the converter was bolted to the flexplate first , then the trans installed on to the engine? If so... broken pump is the result.

As it sit now, sounds like a broken pump may have happened
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-31-2013, 08:39 PM
Registered User
 
Join Date: Jan 2013
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
thanks guys should of joined hot rodders years ago when i put trans in ,i did it the wrong way fex plate to motor then tc to flex then bell trans to tc ,bugga just wandering i still have my old c4 trans is it possible to swap pumps? any suggestions will be much appreciated,cheers.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-01-2013, 08:56 AM
rick 427's Avatar
Registered User
 

Last journal entry: The Cheetah
Last photo:
Join Date: Feb 2012
Posts: 264
Wiki Edits: 0

Thanks: 0
Thanked 17 Times in 17 Posts
I don't know what year trans you got....65-69 pumps will interchange.Then 70-77.Then 78-81,followed by 82-86.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 02-01-2013, 03:01 PM
Registered User
 
Join Date: Jan 2013
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hi there my stock trans c4 was 71 an c4 that i put in wrong is a 77or78 so i may be able to swap? ganna drop tans today.then see how to go about changing pumps.wandering if any specialist tools will be needed.cheers
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 02-03-2013, 02:41 AM
Registered User
 
Last wiki edit: Transmission identification
Join Date: Mar 2008
Location: Terra
Posts: 703
Wiki Edits: 85

Thanks: 0
Thanked 26 Times in 24 Posts
Quote:
Originally Posted by rick 427 View Post
I don't know what year trans you got....65-69 pumps will interchange.Then 70-77.Then 78-81,followed by 82-86.
65 and 66 pumps used an o-ring seal. All later versions used a gasket seal. Using the wrong type can result in leaks.

70 to 81 all directly interchange. Only difference is sealing ring width.

*******

OP. No specialist tools needed. It is possible, though unlikely, that your pump is ok. Check it out before you replace it.

Also check the converter snout. Sometimes it can get damaged in situations like this. Check your bell for cracks, especially around your motor bolts.

If your input shaft does not slip out easily, you could have damaged your forward drum.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 02-04-2013, 02:30 AM
Registered User
 
Join Date: Jan 2013
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hi there iv dropped trans today, and il ispect all that youve mention, i have my other c4 which ive started to take apart just so ive got some idea how to remove pump safely ive removed bell,pan,vaules,bolts, but pump hard to get out, any sugestions. mate how can i tell if my pump on other trans is ok cheers.
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 02-04-2013, 09:32 PM
Registered User
 
Join Date: Jan 2013
Posts: 24
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
hi there i checked bell 4 cracks ,none, input shaft comes out smoothly, checked converter snout and there is a slight kinck, i put cv to case and she landed sweet and spun freely i also put cv on donor pump and it landed sweet on that case too. gana take to machanic see if they can do swap, as im not to familier on how to do swap,got that dam pump off the donor at last. if theres any thing im missing let me know,cheers for help much aprciated.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing starter motor on SBC v8hed Electrical 5 10-27-2010 08:48 AM
Need advice for installing new crate motor lon77 Engine 12 02-26-2007 10:08 AM
Installing the motor mounts? Mike M Engine 1 12-24-2005 01:08 AM
Engine Locked after installing C4 Trans mustangcobra351w Transmission - Rearend 6 08-05-2004 12:49 PM
installing motor with aluminum heads JH30906 Engine 3 06-05-2003 04:30 PM


All times are GMT -6. The time now is 04:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.