Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   MSD coil (http://www.hotrodders.com/forum/msd-coil-45968.html)

mitmaks 08-19-2004 11:45 PM

MSD coil
 
Ok, ive put MSD 2 Blaster coil on my 68 Dodge charger's 440 and now voltage shows that it doesnt charge, stays in "-" area even when i get on it and its always stayed in "+" area or voltage gauge, what did i do wrong, is it draining battery cause its 45000volts performance coil

lluciano77 08-19-2004 11:53 PM

The voltage stays the same on the primay side of the coil. 12-14V
A volt meter does not tell you much at all about your charging system. That is what an ammeter is for.

The new coil is drawing more amperage. You may need a higher amperage rated alternator. Or, maybe the one you have isn;t charging where it should be. A dead cell in the bettery could also cause ampacity loss.

mitmaks 08-19-2004 11:56 PM

no alternator is fine, battery is brand spanking new, optima style battery $150, just changed coil and this happened

lluciano77 08-20-2004 12:08 AM

If you aren't having any troubles other than your gage reading differently. Don't worry about it. If any problems arise get an alternator with a higher amp rating.


All times are GMT -6. The time now is 10:05 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.