Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Suspension - Brakes - Steering (http://www.hotrodders.com/forum/suspension-brakes-steering/)
-   -   Mustang II bump steer, drifting (http://www.hotrodders.com/forum/mustang-ii-bump-steer-drifting-41916.html)

Chev283 06-19-2004 05:37 PM

Mustang II bump steer, drifting
 
1 Attachment(s)
I have a '74 Mustang II front suspension in my '34 Ford which I actually cut out of a junkyard Mustang II back in '81. I set the front assembly, crossmember included, in the '34 frame with a good bit of work and a careful watch on the installation of the strut rod mountings and location, all of which I did myself. It is basically a stock Mustang II with rubber bushings and the strut rod mounted on a 3/8" plate and gusseted on both sides and the frame boxed inside of the mounting location. The rack is a stock Mustang II power rack driven by a SBC power steering pump with a restrictor to limit the pressure from the GM pump. If I remember right I bought the front springs from a company now out of business called A-1 Springs. I believe they are 300lb springs. The front tires are BF Goodrich radial TA's 205/55 R15 with 26.5 lb of air.

Problems:
1: When I hit a set of railroad tracks or a pothole, I get a lot of bump steer both directions of the steering wheel.

2: The car rides very stiff even with stock '74 Mustang shocks and seems to slam the car way too hard if I hit a pothole.

3. The car drifts in the lane I'm driving in and tries to go either direction if I let go of the wheel. I suspect a camber problem here, but not sure.


Any help on this stuff would be appreciated. I searched through some of the archives but didn't get a hit.

Thank you in advance.

Chev283

willys36@aol.com 06-19-2004 07:09 PM

I have installed several stock MIIs and have had super results. Can't imagine how you could have bump steer if you installed the R&P in the stock location and not changed other geometry. Did you mount the strut rods with the pivot point directly in line with the pivot plane of the bottom A-arm? That is important. Has it done this from day one or just start to act up recently? If the latter, check things carefully, especially strut rod brackets that may have broken due to fatigue. Check carefully, those cracks are hard to see sometimes. Did you mount the X-member with the center of it level and with the frame at ride height? If not, that may account for the rough ride and wandering 'cause the geometry isn't correct at some positions of the travel. Also, are the lower A-arms level when the car is fully loaded and ready to run? That is the design spec. If they slope way up or way down, the suspension is operating out of range. It doesn't sound like you have bump steer per se if the wheel jerks both ways. That sounds like an alignment problem that is allowing the wheels to not track forward. True bump steer pulls the wheel one direction only when the steering rods and A-arms are moving in different arcs. Has it been professionally aligned? Check toe-in. The front of the tires should be 1/8" to 3/16" narrower than the back.

Chev283 06-19-2004 08:15 PM

Thanks Willys

A few good things to check, but a few are already good. The X-member is level and centered in the frame at ride height, the lower control arms are level. I did check the strut brackets, but will re-check centerline and look for cracks.
Can't imagine the centerline being off since I did not modify the struts at all from the original '74, just made the brackets to fit the original geometry.

I'd say these problems are fairly new, but always existed to a lesser degree. The car was aligned last in 1977, and that was not a high quality shop. My most recent change was to the 205/55 R15s from 195/70 R14s which took away a lot of rubber height, and lowered the tire profile a good bit. The 15 inch wheels have about an inch more of offset than the 14s did, so I might be trying to drive a "ricer" without even knowing it. I'll check some fellow rodders here in Phoenix and see if there is anybody still alive who knows how to align a '74 Mustang II.
I appreciate your response.

Chev283


All times are GMT -6. The time now is 06:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.