Mustang II ignition switch wiring - Hot Rod Forum : Hotrodders Bulletin Board -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 12-09-2008, 12:18 PM
Registered User
Join Date: Nov 2003
Location: Harrison, AR
Age: 79
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Mustang II ignition switch

I am using the running gear from a 1977 MustangII in a 1941 Ford street rod, including the steering coulum. The engine is a 302 efi from a 1990 Crown Victoria with an aftermarket wiring harness. The harness requires a connection to the ignition switch that is hot during run and start. Is the red/litblue wire from the switch to the coil hot during start? Logic tells me it should be but mine isn't, nor are any of the other wires from the switch. Any information you could provide would be greatly appreciated.
John Hawes

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 12-09-2008, 02:18 PM
OneMoreTime's Avatar moderator
Last wiki edit: Health and safety in the shop or garage
Last journal entry: Yard Dog pic
Last photo:
Join Date: Jul 2004
Location: Washington State
Age: 71
Posts: 8,183
Wiki Edits: 3

Thanks: 156
Thanked 315 Times in 285 Posts
Moving to electrical..I generally try to get a chiltons manual for the donor car to help me sort out the wiring...

I have tried most all of it and now do what is known to work..
Reply With Quote Quick reply to this message

Recent Electrical posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
95 Camaro fan switch problem / ignition key problem human_forklift Electrical 12 05-29-2015 08:57 PM
How to properly mate a GM pump to a Mustang II rack Centerline Suspension - Brakes - Steering 73 10-31-2009 12:59 PM
Ignition system info................ poncho62 Electrical 18 10-11-2008 11:10 PM
Mustang II front shocks not "tall" enough BobbyG-39 Suspension - Brakes - Steering 8 08-10-2004 06:36 AM
Mustang II bump steer, drifting Chev283 Suspension - Brakes - Steering 2 06-19-2004 09:15 PM

All times are GMT -6. The time now is 01:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.