My AirBag light is on and no air coming out of vents - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-03-2011, 01:01 PM
Registered User
 
Join Date: Jun 2011
Location: United States
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
My AirBag light is on and no air coming out of vents

Hey guys,

I have a 2004 Dodge Neon SE that I just bought and the airbag light is on and there is no air that comes out of the vents when you turn on heat or A/C and the defroster doesnt turn on. The horn still works but I've heard this can be related to a bad ground or something but not to sure. I'd hate to replace the clockspring or something if its just a wire you know.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-03-2011, 07:53 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,436
Wiki Edits: 0

Thanks: 230
Thanked 295 Times in 274 Posts
You have 2 seperate issue, the first one SRS lite (airbag) could be the clockspring,they can fail on the power side as well as the ground side,if the ground fails the horn wont work ,and the airbag light will light.If the airbag power side goes open the horn will work but the airbag light will illuminate.
Did you retrieve a code for the driver side deployment loop open circuit?
The air flow issue....does air come out the defrosters? Do you hear the HVAC fan running? More info needed to help here.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-03-2011, 08:20 PM
Registered User
 
Join Date: Jun 2011
Location: United States
Posts: 15
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I hooked up a code reader and it came back, system voltage low. Not sure if that means anything. There is no air that comes out the defroster. when i turn it on i dont hear or feel anything.
What do you mean by airbag power side goes open?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-04-2011, 07:32 AM
Registered User
 
Last wiki edit: General Motors transmissions Last photo:
Join Date: Mar 2006
Location: near Yellowstone park
Posts: 4,479
Wiki Edits: 27

Thanks: 13
Thanked 285 Times in 265 Posts
used car ?

some used car mechanics are known to send cars out with an inop or defective air bags, get them sold the cheapest patch job possible.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Airbag Light ziggarot Electrical 2 03-21-2011 07:26 PM
No Air coming out of defrost only front vents 350chevypower General Rodding Tech 23 08-30-2010 09:28 PM
Blazer airbag light. BToops396 Electrical 2 02-11-2010 08:38 PM
sensor light keeps coming on wiseguy50 Engine 6 01-14-2006 07:21 PM
generater light is coming on 1cool62 Electrical 4 01-05-2003 07:01 PM


All times are GMT -6. The time now is 11:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.