My engine runs much better without an air cleaner - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-04-2013, 08:11 PM
Registered User
 
Last photo:
Join Date: May 2012
Location: Bayonne NJ
Age: 21
Posts: 164
Wiki Edits: 0

Thanks: 5
Thanked 2 Times in 2 Posts
My engine runs much better without an air cleaner

hey guys I have a basic 350 chevy bored .60 over, with around 10:1 compression, iron heads, comp cam xe 274h, performer eps manifold with a 1 inch open spacer and an edelbrock 1405 600 cfm carb

I've played with the idle mixture screw leaning out the mixture with the filter on but it still kinda runs like crap

i know i'm not running rich with a stock 1405 600 cfm carb, especially with the compression cam and headers i'm running

any who i took the the air cleaner off and my engine is as happy as can be, so much more torque and power down low, idle quality is also great now, I can really feel a genuine power increase

i know it isn't good to run without an aircleaner but my engine runs so much better without it

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-04-2013, 09:18 PM
68NovaSS's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Working with chromed bolts
Last journal entry: New to me T-Bucket
Last photo:
Join Date: Sep 2002
Location: Nine Mile Falls, Washington
Posts: 5,217
Wiki Edits: 9

Thanks: 100
Thanked 130 Times in 121 Posts
What's your question? Just sounds like you have a restrictive air filter or element.
__________________
Boost adds dignity to what would otherwise be a vulgar brawl...

Midnight Sun Street Rod Association
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-04-2013, 09:35 PM
Registered User
 
Last photo:
Join Date: May 2012
Location: Bayonne NJ
Age: 21
Posts: 164
Wiki Edits: 0

Thanks: 5
Thanked 2 Times in 2 Posts
lol my question is if this is normal, could it be a tuning issue ?

it's a standard air cleaner with a 14x3 spectre element, it shouldn't be as restrictive as it is
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-04-2013, 10:07 PM
vinniekq2's Avatar
Registered User
 
Join Date: Jun 2012
Location: BC,Canada
Age: 56
Posts: 7,429
Wiki Edits: 0

Thanks: 292
Thanked 708 Times in 683 Posts
post a picture
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-04-2013, 10:14 PM
Registered User
 
Last photo:
Join Date: Jan 2006
Location: cornelius
Posts: 665
Wiki Edits: 0

Thanks: 29
Thanked 12 Times in 12 Posts
Its an oiled spectre unit correct? The only thing I can think is its over oiled. or super dirty. They actually flow really well, some say as good or better than a K&N.

I would suggest going out and buying a cheap O Fram 14x3, or bigger filter and see if there is any difference. When you get into that size filter It's unlikely your going to get any noticeable restriction.

What heads are you running? The Edelbrock 600 may be a little small for that combination.

PS I have a 383 with the same cam, vortec heads a 850DP carb and a 12x3 spectre filter... I have never noticed any difference between air filters. I have tried up to a 14x5 Air hog filter.

Ohh yeah, what are the details of the setup? any kind of snorkels? scoops on the hood? ect? Quite often you can actually loose power without a filter because of turbulence. Filters can sometimes straighten out the flow and make you more power. My guess is over oiled.

and yes post a pic please
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 05-04-2013, 10:23 PM
Registered User
 
Last photo:
Join Date: May 2012
Location: Bayonne NJ
Age: 21
Posts: 164
Wiki Edits: 0

Thanks: 5
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by xxllmm4 View Post
Its an oiled spectre unit correct? The only thing I can think is its over oiled. or super dirty. They actually flow really well, some say as good or better than a K&N.

I would suggest going out and buying a cheap O Fram 14x3, or bigger filter and see if there is any difference. When you get into that size filter It's unlikely your going to get any noticeable restriction.

What heads are you running? The Edelbrock 600 may be a little small for that combination.

PS I have a 383 with the same cam, vortec heads a 850DP carb and a 12x3 spectre filter... I have never noticed any difference between air filters. I have tried up to a 14x5 Air hog filter.

Ohh yeah, what are the details of the setup? any kind of snorkels? scoops on the hood? ect? Quite often you can actually loose power without a filter because of turbulence. Filters can sometimes straighten out the flow and make you more power. My guess is over oiled.

and yes post a pic please
I'll try cleaning the filter tomorrow and see if it makes a difference

once i took the filter off the idle shot up, i had to turn it down actually

power is up across the powerband, especially down low, crazy.

i'm running ported 601 heads with 2.02 and 1.60 valves

Last edited by xzero117; 05-04-2013 at 10:31 PM.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 05-04-2013, 10:57 PM
Registered
 
Join Date: Apr 2013
Location: Burlington, IA
Posts: 39
Wiki Edits: 0

Thanks: 2
Thanked 6 Times in 6 Posts
I agree with too oily/dirty and it maybe being to restrictive.

im running a spectre cone on my truck and ive used them alot in the past and the only problem ive had is when they need to be replaced but that happens with everything. I AM thinking of switching to a 4" though. Since I installed the 3" CAI it sounds supercharged and puts out better than stock but im thinking the sound is because the plumbing is too restrictive. Which is weird because ive never heard this issue with my supercharged GA or any of the previous autos and autos ive heard them being on whether being stock super or turboed. If you do drive it filterless dont do it long and especially leave it parked.
A friend of mine did that after getting home I swung over to meet with him to go cruising the next day...we go to leave and Im now sitting there waiting and waiting. Then I see him jump out of the car throwing a hissy fit so I get out go over he explains he tries it again and it just bogs. Were both stumped because we both know he cherishes that car....kinda lol. Every spare minute we had over the next 3 days we spent trying to figure it out checking and rechicking everything. We gave up but didnt quit searching online and talking to everyone we know for answers until the weekend found nothing to help us. So we started to tear it down, it has to be internal and it was...there was a huge mess of twigs grass small trash litter flowers weird crap..clogged everywhere inside of everything. First thought was sabotage....two days later we found out no one did it...it didnt hit us until we took the motor out and started tearing it down that his girlfriend finally says that she thinks its what was a birds nest....yeap sad. So we searched if it could be and we found its rare but it could happen due to the engine being warm and secluded a bird decided to make it home. We felt like idiots. It did end up costing him 3500 in parts though.
I usually go through 2 a year and only drive the truck a total of 1200 miles a year. Another indicator of upgrading lol. She sucks in a good way ;-)
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 05-04-2013, 10:59 PM
Registered User
 
Last photo:
Join Date: May 2012
Location: Bayonne NJ
Age: 21
Posts: 164
Wiki Edits: 0

Thanks: 5
Thanked 2 Times in 2 Posts
this engine is in my jeep, nothing fancy about the hood
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 05-05-2013, 12:36 AM
techinspector1's Avatar
Senior Curmudgeon
 
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 72
Posts: 12,591
Wiki Edits: 326

Thanks: 700
Thanked 885 Times in 752 Posts
Well, you know what I'm thinkin'. Float set too high, fuel pressure excessive and overpowering the float/needle & seat. Motor running way rich with the air cleaner in place, leaning out a little without the filter.
Reply With Quote Quick reply to this message
The Following User Says Thank You to techinspector1 For This Useful Post:
OneMoreTime (05-05-2013)
  #10 (permalink)  
Old 05-05-2013, 08:45 AM
RWENUTS's Avatar
Registered User
 
Last photo:
Join Date: Nov 2011
Location: Nanaimo, BC, Canada
Age: 62
Posts: 1,874
Wiki Edits: 0

Thanks: 47
Thanked 200 Times in 189 Posts
If you're running a low profile cleaner base the top lid could be too close to the vent tube making it run worse.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 05-05-2013, 09:51 AM
malc's Avatar
Living At The Speed Of Life
 
Last photo:
Join Date: Jun 2003
Location: Espaņa Right Coast
Age: 63
Posts: 3,245
Wiki Edits: 0

Thanks: 86
Thanked 72 Times in 69 Posts
Quote:
Originally Posted by xzero117 View Post
any who i took the the air cleaner off and my engine is as happy as can be, so much more torque and power down low, idle quality is also great now, I can really feel a genuine power increase
How did you calculate this improvement ?
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 05-05-2013, 07:15 PM
Registered User
 
Last photo:
Join Date: May 2012
Location: Bayonne NJ
Age: 21
Posts: 164
Wiki Edits: 0

Thanks: 5
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by malc View Post
How did you calculate this improvement ?
when I drive around at 1200 rpm or so it doesn't feel like i'm dogging it like when i had my filter on there

the car feels happy to chug along at 1200 rpm all of a sudden when before i need to be at at least 1400rpm

all my shift points have gone down too
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 05-05-2013, 07:24 PM
NEW INTERIORS's Avatar
Believe in yourself !!!!!!
 

Last journal entry: 41 WILLYS FRAME
Last photo:
Join Date: Jul 2007
Location: In My Shop..
Age: 49
Posts: 10,016
Wiki Edits: 0

Thanks: 1,161
Thanked 506 Times in 376 Posts
It want's to breathe !!!!!
Reply With Quote Quick reply to this message
  #14 (permalink)  
Old 05-06-2013, 08:31 AM
Registered User
 
Join Date: Jun 2010
Location: TX
Posts: 1,153
Wiki Edits: 0

Thanks: 0
Thanked 101 Times in 93 Posts
I found out many years ago that running without a paper element air cleaner can be worth 0.2 second ET.

I rather not admit how many years ago that was.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holley Hi-Tek Air Cleaner VS Spectre Dual Cold Air Intake the82elco Engine 1 12-13-2012 03:38 PM
Runs Like Crap With Air Cleaner On - why? leejoy Engine 30 11-16-2010 06:08 PM
New air cleaner? Scotto Hotrodders' Lounge 6 02-26-2009 07:28 PM
Runs better without air cleaner NovaSS350 Engine 7 08-28-2004 07:03 PM
Air cleaner Help srd1 Engine 6 01-28-2004 05:50 PM


All times are GMT -6. The time now is 01:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.