My Engine Is Smoking - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-28-2003, 03:54 PM
pintoperformance's Avatar
New Member
 
Last photo:
Join Date: Oct 2003
Location: TEXAS
Age: 71
Posts: 20
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
My Engine Is Smoking

I HAVE A 1973 MERCURY COMET WITH A 302 .30 OVER REBUILT ENGINE

THE ENGINE WAS GONE COMPLETELY THROUGH AND THE FOLLWING WAS INSTALLED

1. NEW KEITH BLACK PISTONS/RINGS
2. NEW LUNATI .512 LIFT CAMSHAFT
3. NEW WINDSOR JUNIOR HEADS-VALVES-SPRINGS ETC
4. NEW MELLING HIGH OUTPUT OILING SYSTEM
5. NEW WEIND INTAKE MANIFOLD
6. NEW ELDEBROCK PERFORMER 600 CFM CARB
7. MALLORY DUAL POINT DISTRIBUTOR AND HIGHOUTPUT COIL
8. NEW CRANE ROLLER TIP ROCKERS
9. NEW SERPTINE BELT SYSTEM AND FLEX FAN
10.NEW HEDMAN HEADERS/FLOWMASTER EXHAUST SYSTEM
11.ENGINE WAS COMPLETELY BALANCED AND BLUEPRINTED

NOW THE PROBLEM
THE ENGINE HAS LESS THAN 500 MILES SINCE BUILD-IT SMOKES WHEN I START UP AND CONTINUES TO SMOKE AS IT WARMS UP-WHITE SMOKE--COMES OUT OF BOTH EXHAUST PIPES.
IT SEEMS TO BE RUNNING ON 7 CYLINDERS LIKE ONE OF THE PLUGS IS FOULED....

DOES NOT BACKFIRE/DOES NOT OVERHEAT...
I DID ADD SOME ADDATIVE TO THE GASOLINE TO KEEP IT FROM GOING SOUR. THE ENGINE HAS ONLY BEEN RUN OCCASIONALY SINCE REBUILT 11 MONTHS AGO AND HAS NOT BEEN DRIVEN FOR THE SAME TIME PERIOD.

ANY IDEAS ON WHAT IS MAKING THIS ENGINE SMOKE AND IS THERE A SIMPLE CURE??

PS HERE IS A PICTURE OF THE CAR

thanks,
Mike

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-28-2003, 04:45 PM
Jmark's Avatar
Hotrodders.com Moderator
 
Last photo:
Join Date: Sep 2003
Location: phoenix
Age: 61
Posts: 4,786
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
If its white white smoke, my first ck would be the vacuum modulator if it has an automatic. Jack it up, pull of the hose and if any tranny fluid drips from either the modulator or hose, replace the modulator, clean the plug and try it again.

Mark
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-28-2003, 05:23 PM
11echo's Avatar
Old Guys Rule!...EVERYTHING!
 
Last photo:
Join Date: Jun 2003
Location: Bakersfield, CA
Age: 64
Posts: 467
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
What "type" of rings did you use? ...cast iron, Moly, chrome? Cast iron rings would seat inside 100 miles, BUT the others take alot longer to seat. Until they do you'll get some smoking. Now this isn't like a fog machine, just alittle bit of smoking. A good way to seat the rings is take the car out on the road and take it up in RPMs in low gear then let off real quickly and let it coast down to idle. Do this a number of times and it'll will help your rings seat quicker. Good Luck! ...Mark

P.S. ...This should be a little blue smoke, if it's white and there's alot of it, you could be leaking coolant into the combustion chamber.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 10:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.