My mad dash to stupidity - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-25-2012, 09:34 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,752
Wiki Edits: 0

Thanks: 50
Thanked 245 Times in 212 Posts
My mad dash to stupidity

So, in a nut shell, 350, 416 heads, small cam, yada yada yada, had it running Sunday, did cam break in, brief but excellent road test, all good right? Get home, oil leak at front and rear, assume because I used the dam rubber ends that that was the issue. Pull the intake, reseal, bolt back on, notice port alignment isn't great, and I did have very lightly dremel intake bolt holes to get it lined up, I assumed due to the heads being milled. But, dist won't sit flush, again, same assumption, grab some shims, slap it together, still not happy with port alignment and how the intake bolts go in....pull it apart, and try to figure out how to guage required machining to the intake to make it work...(head milling unknown) so while sitting,and stewing, as this thing needs to run tommorow, I reach over and grab beat up and oily old performer, as opposed the the port matched, painted, clean brand new Chinese knock off that I was using, and low and fkng behold, it fits flawlessly, pull all the fittings, brake clean the hell out of it, swap everything over, and install, absolutely perfect....I'm pissed and happy at the same time....its not as pretty, but I suspect will function right.....
Moral of my story.....
Stop making stupid assumptions when your actually clueless....
************
The end
Goodnight

    Advertisement

Last edited by 68NovaSS; 09-25-2012 at 10:19 PM. Reason: Profanity
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-25-2012, 09:47 PM
F-BIRD'88's Avatar
Yada Yada Yada
 
Last photo:
Join Date: Oct 2005
Location: Ontario, Canada
Posts: 9,523
Wiki Edits: 0

Thanks: 2
Thanked 330 Times in 327 Posts
Ya I don't have a lot of faith in ProComp stuff. I have had good luck with Professional Products intakes and
Edelbrock and Holley and Weiand intakes. I always inspect before I pay.

Back in the 70's the Edelbrock stuff was just as bad.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-25-2012, 09:58 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,752
Wiki Edits: 0

Thanks: 50
Thanked 245 Times in 212 Posts
Quote:
Originally Posted by F-BIRD'88 View Post
Ya I don't have a lot of faith in ProComp stuff. I have had good luck with Professional Products intakes and
Edelbrock and Holley and Weiand intakes. I always inspect before I pay.

Back in the 70's the Edelbrock stuff was just as bad.
Yah, it came off a fairly healthy roller 355 my buddy has, I have zero idea why it worked for him, and not me....but I swear to God I'm going to enjoy using it a a paperweight....I'm completely stunned bynhownmuch better the port alignment and fit is with the edelbrock....one thing I don't get, the knock off has coolant passages at the rear that obviously line up with the heads, on the edelbrock they are not there, only the front ones.....I had this intake on my Malibu wagon with no issues....why are they blocked? And what will that do?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems caused by stupidity chevythmpr Engine 2 11-06-2009 09:36 PM
Rear disc stupidity kleen56 Suspension - Brakes - Steering 5 04-06-2009 06:52 PM
Supreme Stupidity RCastle Hotrodders' Lounge 28 06-30-2005 11:31 AM
Embarrassing, needed to share my stupidity scott011422 Hotrodders' Lounge 8 07-19-2003 04:47 AM
Piston replacement because of stupidity! Rodrunner Engine 3 11-22-2002 02:27 AM


All times are GMT -6. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.