my moter coughts back throw the carb at low rpm - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-06-2004, 03:53 AM
302truck's Avatar
New Member
 
Join Date: Jan 2004
Location: michigan
Posts: 20
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
my moter coughts back throw the carb at low rpm

i have a 302 that has jist been rebilt it hast roush 200 winser lite heades and a comp .520 intack 523 exaust.with roller rockers.edelbrock intake and holly 6oo singole feed carbat low end it is reil sluges untile about 2000 then it rilly comes alive i have it in a 1976 ford f150 4x4 with a three speed over drive and in forthe gear at 60 ites rilly low rpm . and some times it coughts back throw the carb can iny one tell me how to fix it and why ites doing it

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-06-2004, 06:48 AM
Technical Support Barry Grant
 
Last photo:
Join Date: Jul 2003
Location: Dahlonega, GA
Posts: 1,503
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Normally a backfire through the carburetor is an indication of being too lean. This may also be why your acceleration is sluggish.

Assuming you have your idle, and floats set properly we'd recommend going larger on the squirter nozzle size.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-06-2004, 06:54 AM
Frisco's Avatar
Glad To Be Here
 
Last photo:
Join Date: Nov 2002
Location: Canton, North Carolina
Age: 72
Posts: 2,244
Wiki Edits: 0

Thanks: 0
Thanked 8 Times in 8 Posts
Timing is too retarded.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-06-2004, 09:15 AM
302truck's Avatar
New Member
 
Join Date: Jan 2004
Location: michigan
Posts: 20
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
thank you for the addvice. i ask the comp cam teckes and they told me to set the timeing at 12 to 14 but it woldint even run at that so the book seed 10 so thates what i got it at.i tried the idole mix up and down but still the same. every thing is brande new so ites go me stumped
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 01-06-2004, 09:49 AM
Frisco's Avatar
Glad To Be Here
 
Last photo:
Join Date: Nov 2002
Location: Canton, North Carolina
Age: 72
Posts: 2,244
Wiki Edits: 0

Thanks: 0
Thanked 8 Times in 8 Posts
What problems did you have when you increased the initial timing?

Did you have the vacuum advance hose disconnected from the cannister and plugged when you set the timing?

Are you running the vacuum advance hose to the 'Full' or 'Ported' connection? Try both and see which works best for you. I prefer the 'Full' port connection.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.