My Vette is Weak! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-29-2001, 06:18 AM
New Member
 
Join Date: Nov 2001
Location: omaha
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post My Vette is Weak!

1974 Vette with 8.5:1 L48 engine. 95,000 miles. Cant even turn the tires with the brake on! Just dogs out bad until it gets rolling, then it will go. Runs great on the highway and will do 130 no problem. I've tried all the easy stuff, points, cap, rotor, wires, plugs and I rebuilt the quadrejet last night. No Help! It does take some oil and smokes a bit when first started and under hard acceleration. Also, I have to have the timing set to about 15-20 degrees btc to get the thing to run halfway descent. Is it time for a complete rebuild? Am I missing something? Did a 74 L48 ever have any power? I've only had the car since spring and really didn't drive it that much this summer, maybe 1500 miles. I checked the oil once this summer and it was fine. Checked it again last night and it was 1.5 quarts low!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-29-2001, 09:23 AM
Member
 
Join Date: Jun 2001
Location: Red Hook N.Y. USA
Posts: 51
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Replace it with a ZZ4, Then it`ll act like a Vette.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-29-2001, 01:18 PM
New Member
 
Join Date: Nov 2001
Location: omaha
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Well thats a simple solution for a man with your money! Actually, I have a local engine rebuilder that will rebuild the one I have with 9.5 hypertectic pistons, speed pro cam and he currently has a set of cast iron 2.02 heads that are ported out with screw in studs. He'll do the whole thing for $1150 which is a little closer to my price range than the crate motors. I guess I still would like some suggestions on my current motor short of a rebuild however.
Thanks
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-30-2001, 10:27 AM
Keith Boisvert's Avatar
Member
 
Join Date: Oct 2001
Location: Fitchburg, Ma
Age: 43
Posts: 49
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

I had a 75 vette w/the same problem. It had no bottem end power. It did smoke a little, but that was the valve seals. I installed an edelbrock performer rpm kit(intake,carb,cam/lifters) along with a Mallory distributer and I definetly noticed a difference. It was still no power house, but I did notice a big increase in low end torque. I have never had good luck with the quadrajets, even when they are rebuilt, you could try a 600 or smaller carter/edelbrock carb or a carb spacer(room permitting)and you might notice enough of an increase to satisfy you in the meanwhile.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 12-01-2001, 02:51 AM
New Member
 
Join Date: Oct 2001
Location: North East
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

If by chance the engine is still in good shape.(I know it's a high milage smog motor BUT) As you say you can run @ 130 MPH !!! I think you might check your rear end ratio to see where your at... Rear end ratio can kill the engines performance potential in a heart beat.

[ December 01, 2001: Message edited by: willy77 ]</p>
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 12-01-2001, 04:21 AM
Tom Tom is offline
Member
 
Join Date: May 2001
Location: agawam ma
Posts: 323
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

the stock rear end ratio for all 74 vetts is 308 unless the original buyer ordered a different gear the L48 is the same engine basically as what came in every other chevrolet with a 4bbl carb and by now its probably tired.So now it a depends on what kind of performance you are looking for... and what kind of condition the rest of the vette is in.... when you tune a corvette you tune the whole car not just the engine...If it were mine I would leave the stock rear ratio and go for a 350 w/TPI setup and a 700R tranny use an aftermarket harness set up for speed dencity then do the suspention.A TPI will give outstanding performance to around 5000rpms and a 308 gear is exactly what the 700R loves plus its overdrive for mileage
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 12-01-2001, 09:51 AM
The Vandal's Avatar
Engine Tech Addict
 
Join Date: Oct 2001
Location: Clinton, MS
Age: 42
Posts: 125
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Yeah, well I'd recommend cashing out your 401k and getting a second morgage on the house so you can drop in that 14-71 blown, electronically injected, 672 Rat. Then you can go full chassis and 4-links and pull the sticks on a 4-speed lenco. Let me know how it turns out......The Vandal
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 12-04-2001, 01:12 AM
New Member
 
Join Date: Oct 2001
Location: North East
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

I think that member TOM has the best answer! A good junk yard cutout might get you most of what you need Tranny and Engine which are bolt-ins and
you can work on a budget or if you got the bucks go for it All New or rebuilt!!! Have Fun...

[ December 04, 2001: Message edited by: willy77 ]</p>
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 12-04-2001, 06:18 AM
New Member
 
Join Date: Nov 2001
Location: omaha
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Thanks guys! I didn't realize the rear ends were that high of gears! I assumed a Vette would use 3.73 or so. If it is a 3.08, that explains alot! Also, it is a 400 tranny which I know takes a few more HP's to turn than a 350 tranny. I have done the 700R4 conversion before in a 56 Chevy with a rebuilt 350 and a 3.73 rear end, and that car runs hard! It will definately light up the tires! Are the Vette rear ends at least posi units? Can a guy change the gears in them without changing the whole unit?
Thanks again!
Tom
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 12-04-2001, 01:39 PM
Tom Tom is offline
Member
 
Join Date: May 2001
Location: agawam ma
Posts: 323
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

I havn't ever seen a non posi vette rear If it's any use to you all 79 autos were factory stock with 355s and the most popular gear other than stock were 370s and all pumkins from 63 to 79 will fit
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 12-14-2001, 04:47 PM
Registered User
 
Join Date: Dec 2001
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Would not trust timing. Feel problems are related to chain/cam timing. Has anyone jerked the distributor and not put it in right. You can get it in to the pump shaft and still be out of sequence. Good luck.
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 12-14-2001, 05:06 PM
Member
 
Join Date: Nov 2001
Location: iowa
Posts: 127
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

Throw a timing light on it and check the vacume advance if its not working it will be dead.
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 12-16-2001, 12:41 PM
New Member
 
Join Date: Nov 2001
Location: omaha
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Thanks for all the input guys. The timing does have me baffled. As far as I know, the dist has never been pulled. Its not that I don't have enough adjustment to set the timing wherever I want, its just that it doesn't run worth a ***** unless its advanced clear up to 18 degrees, with vacuum advance disconnected. The advance does work and holds vacuum. I was going to put in an HEI, but it is a mechanical tach drive dist, so I would loose my tach if I change it. Plus, it has a cool chrome cover that would never fit over an HEI. I think I will get a pertronix conversion kit for the dist I have when I have the engine rebuilt. My current plans are to find a set of 64cc heads, (would like to get to 9.5 or 10 to 1 compression) and rebuild the motor/heads, put in some hypertectic flat tops and a slightly bumpy cam. (speed pro with .443 exhaust lift, 288 sae exhaust duration 214 dur at .050) Thats the cam I used in the 56 anyway, and it seems to idle good and have good throttle response. I think I'm going to stay with the stock cast iron intake and exhaust manifolds and the stock Quadrajet for now. I'd also like to throw in a 2000-2500 stall converter. I figure this should put out at least 275hp as compared to the 180 stock HP!! Not looking to make a hot rod, just want some throttle response. What do you all think??????

[ December 16, 2001: Message edited by: tsorens ]</p>
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.