need to build up a strong 700r4 burnt up my last one - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-09-2012, 09:05 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 843
Wiki Edits: 0

Thanks: 12
Thanked 25 Times in 22 Posts
need to build up a strong 700r4 burnt up my last one

i just burnt up the 700r4 in my twin turbo camaro, it was a decently built piece.
tci rebuild kit
mega boost valve
vette servo
beats sunshell
shift kit

any advice to build the next one even stronger
id also like no engine braking except in 1st gear if at all possible
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-10-2012, 06:29 AM
Registered User
 

Last journal entry: 700r4 still running strong
Join Date: Dec 2011
Location: Lakehills Tx
Posts: 459
Wiki Edits: 0

Thanks: 46
Thanked 32 Times in 32 Posts
700r4 burnup

Sounds like you might have to much engine for a 700r4.Their only good for / up to 550 HP. 4l80,4l85,TH400 is what you need..
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-10-2012, 07:47 AM
SSedan64's Avatar
Registered User
 
Last photo:
Join Date: Dec 2007
Location: Macon, GA.
Age: 50
Posts: 6,016
Wiki Edits: 0

Thanks: 0
Thanked 46 Times in 46 Posts
X2^^ on the 80E/85E.
I'm sure that's producing lots of low end torque. Pressure rise probably isn't keeping up with engine's output. A Constant Pressure Valvebody would be an option but, as 'Dogwater' said, probably too much power for the 700R4.

Lonnie at Extreme Automatics has a better designed ValveBody for the 2004R than TCI's CP ValveBody, He may also make them for the 700R4. His supplies constant Max pressure in 1st, 2nd & 3rd gears but, allows TV cable controlled variable pressure in 4th gear. This takes the strain of the Pump when cruising in OD/4th to prevent premature wear.
Also has bolt on SFI 80E Bells for just about any Engine combo.
http://www.extremeautomatics.com/tra...ons/4l80e.html
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-10-2012, 08:58 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 843
Wiki Edits: 0

Thanks: 12
Thanked 25 Times in 22 Posts
Quote:
Originally Posted by SSedan64
X2^^ on the 80E/85E.
I'm sure that's producing lots of low end torque. Pressure rise probably isn't keeping up with engine's output. A Constant Pressure Valvebody would be an option but, as 'Dogwater' said, probably too much power for the 700R4.

Lonnie at Extreme Automatics has a better designed ValveBody for the 2004R than TCI's CP ValveBody, He may also make them for the 700R4. His supplies constant Max pressure in 1st, 2nd & 3rd gears but, allows TV cable controlled variable pressure in 4th gear. This takes the strain of the Pump when cruising in OD/4th to prevent premature wear.
Also has bolt on SFI 80E Bells for just about any Engine combo.
http://www.extremeautomatics.com/tra...ons/4l80e.html
thats prolly how i broke it i still dont know what broke yet need to get it out of the car.

the other night i was rolling down the street in second gear and decided to test the antilag out. i had it set for 2500 rpms so i pushed the button put my foot to the floor and let the boost build and when i came off the button there was a loud pop the car jumped and then nothing motor just free reved and hit the limiter.only 1st gear works now and it has no engine braking

the guys over at probuilt said they can build me one to handle the power my car will make on high boost but i may just swap to a th400 or 4l80 with a full manual valve body so i dont have to worry about the ecm, since i want a transbrake for the car
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
700R4 lost 4th smells burnt Fergusonic Transmission - Rearend 2 05-30-2010 05:30 AM
help me build a strong high reving small block 400 mopar dman16 Engine 53 08-27-2009 11:06 PM
Is my stock 700r4 strong enough? pb9882 Transmission - Rearend 4 05-13-2005 10:37 AM
Rebuilt 700r4 Burnt in 10 miles subman17 Transmission - Rearend 9 02-15-2004 03:41 PM
700R4 strong enough??? catdad2u Transmission - Rearend 7 11-25-2002 08:15 PM


All times are GMT -6. The time now is 09:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.