NEED FUEl GAUGE - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-27-2011, 04:32 AM
Registered User
 
Last photo:
Join Date: May 2011
Location: Chandler,AZ
Posts: 49
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
NEED FUEl GAUGE

Sorry Ive posted already on this but its causing real big problems almost got in a big pile up on freeway but nevermind that once in a lifetime mistake this will be kinda long. So i have a 77 k10 with dual tanks and no fuel gauge the gauge cluster no good wiring is all messed up and rigged causing problems when connected to cluster things are all messed up blinkers are opposite and wipers a switched tried different cluster same problems so just left unconnected and taped up. So ive bought an aftermarket gauge (0-90) to put on just one tank problem is it reads over full or just at quarter tank but doesnt move both sending units are grounded to frame brand new the switch valve works put power to it and it switches but after i connect the green wire back to it and flip switch it doesnt work havent tried another switch but that one was brand new there is 5 wires from the switch
Blue
Pink
Tan
Pink and Black
Red (maybe cant remember)
They are all messed up but they do connect to the switch. One of the pink ones i read was to the the gauge on the cluster, I wired one of the wires from the gauge to that pink one and it read i think 1/4 and stayed there.
Could i just bypass the valve to one tank the outlet and return and leave the valve alone? and how could i wire this up i read the sending unit needs power not much but some could that be the problem and how could i get power to it.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-30-2011, 07:38 AM
Registered User
 
Join Date: Aug 2006
Location: Alexandria, VA
Posts: 1,747
Wiki Edits: 0

Thanks: 4
Thanked 64 Times in 62 Posts
If you are having gauge cluster problems the first fix is to make sure it is grounded. The ground wire is black and it connects to a post on the emergency brake mechanism. If this ground is missing you will get all kinds of weird gauge and light problems. Trust me - check and fix it right now.

I have the wiring diagram for 74/75 dual tanks, and it sounds like it might be close to the same scheme as your truck.

For a five terminal switch in '74 they used:
18g pink - power from fuse box
18g lt green - power to the solenoid under the truck (to activate it)
18g lt blue - to aux tank sending unit
18g tan/white - to main tank sending unit
18g tan - to fuel gauge in dash

It should be a dual pole, dual throw switch (six terminals). In this switch you have two sets of 3 terminals (dual pole), and they can be switched to connect two ways (dual throw).
- The three terminals on the power wire half will have only two wires (pink and lt green). In main position the power on the center terminal connects fused power to the open terminal (no power to solenoid). In aux position it connects fused power to the solenoid line and activates the solenoid to switch the tank.
- The other set will have the tan in the middle terminal , and the other two sending unit wires on the other two terminals. The wire for the aux tank should be on the same side as the power to the solenoid, so that when you switch to aux tank and activate the solenoid it also switches the gauge to that tank.

You can just leave the switch disconnected and with no power to the solenoid the truck will run on the main tank. In my truck the main tank is the passenger side, but later years they switched it to the driver side tank. To get the dash gauge to read you need to get the tan wire from the gauge cluster and connect it to the sending unit wire from the main tank. If all the wires are under the dash you should be able to make the connection there.

Bruce
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with fuel gauge chewyscool Electrical 4 11-13-2008 04:56 PM
Fuel gauge? rj440 Electrical 5 08-14-2007 08:27 AM
fuel gauge akm Electrical 3 10-13-2004 06:00 PM
Fuel gauge oils65mustang Electrical 3 08-04-2004 12:46 AM
Fuel gauge gutless cutlass Electrical 1 01-09-2003 04:53 PM


All times are GMT -6. The time now is 10:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.