need help with 04 speedo questions - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 03-27-2008, 09:35 PM
Registered User
 
Join Date: Jan 2008
Location: texas
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
need help with 04 speedo questions

i have an 04 chevy 1/2 ton p/u. the speedo is stuck on 125mph. i have no idea why. i bought the truck used about 5 months ago everything worked fine untill now. the check engine light is not on. eveything else seems to be working ok. can anyone help

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 03-28-2008, 06:27 AM
Holder350's Avatar
Auto Parts Professional
 
Last photo:
Join Date: Feb 2005
Location: Whitesburg, TN
Posts: 1,037
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
Change the VSS (vehicle speed sensor)

thats probly the reason for the check engine light also.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 03-28-2008, 07:47 AM
302 Z28's Avatar  
Last photo:
Join Date: May 2003
Location: North Texas
Posts: 10,840
Wiki Edits: 0

Thanks: 1
Thanked 86 Times in 73 Posts
We have an 04 Tahoe that the speedo started acting up on. It would slowly fall from 65 to zero and stay that way for as long as the car was running. Eventually the speedo stuck at about 55 mph. Then the Tach started acting up. The Tahoe was still under extended warranty and when I took it in the service writer at the Chevy dealership told me there was a TSB (Technical Service Bulletin) on the instrument cluster. They replaced the entire instrument cluster. I would hate to have to buy one of those things, bet it ain't' cheap. You might be lucky enough to get it fixed if you don't have a huge amount of miles on it.

By the way the speedo is all electronic, no cable involved at all. If the VSS is bad you will see problems in other areas like transmission shift points.

Vince
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 03-28-2008, 08:02 AM
Holder350's Avatar
Auto Parts Professional
 
Last photo:
Join Date: Feb 2005
Location: Whitesburg, TN
Posts: 1,037
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
thats true Vince, Hadn't thought of that. A good test is the cruse control, if it works then the VSS is good if not then the vss is bad
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-04-2008, 03:20 PM
Registered User
 
Join Date: Jan 2007
Location: Plymouth, CT
Posts: 141
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
04 chevy cluster

Chevy had a recall on these if you have less than 75000 miles they will
replace it.
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 05-06-2008, 10:30 PM
Deuce's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Choosing a trailer
Last journal entry: Jan 13 2013
Last photo:
Join Date: Aug 2002
Location: Deuceland USA
Age: 66
Posts: 5,657
Wiki Edits: 6

Thanks: 0
Thanked 9 Times in 9 Posts
Quote:
Originally Posted by jetnow1
Chevy had a recall on these if you have less than 75000 miles they will
replace it.
Just my luck ... my 04 is over the 75 thousand mile mark
Mine wants to act up when it is under 50 degrees ... over 50 degrees ... no problems.
__________________


"I won't be wronged . I won't be insulted, and I won't be laid a hand on. "






Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
TH400 Speedo size Derkyb Transmission - Rearend 0 08-21-2007 06:27 PM
SW speedo question 37fordpickup Electrical 2 12-19-2006 09:14 AM
Speedo calibration novatech Transmission - Rearend 2 02-12-2004 07:46 PM
Questions, questions, questions? slider in wa Transmission - Rearend 2 09-27-2003 02:01 PM
Speedo not working..4spd Trav Transmission - Rearend 5 07-31-2003 01:21 AM


All times are GMT -6. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.