Need help with Powerglide valve body screen - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-08-2009, 07:42 PM
Registered User
 
Last photo:
Join Date: Dec 2009
Location: Hernando, MS
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Need help with Powerglide valve body screen

I am doing a stock rebuild on a Powerglide in a 1964 Impala. This is the original transmission to the car and has never been apart. I have attached a picture of the two screens I have. The longer one fits into the valve body, I removed it while cleaning. The shorter one measures just over 1/2 ". I found it in the bottom of my parts washer when I was finished cleaning parts. I can't find anywhere that it will fit in the upper or lower valve body. Anyone know where it goes? Any help is appreciated.

Thanks,
Todd
Attached Thumbnails
Click image for larger version

Name:	screens.jpg
Views:	81
Size:	8.7 KB
ID:	42419  

    Advertisement

Last edited by Todd68390; 12-09-2009 at 02:16 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-09-2009, 01:51 PM
junior stocker's Avatar
Registered User
 
Join Date: Feb 2004
Location: Everett, Washington
Age: 62
Posts: 819
Wiki Edits: 0

Thanks: 0
Thanked 9 Times in 8 Posts
I looked in both Chiltons and Motors Manuals, and the "long" screen is'nt even made note of, but I've come across that screen many times; I build Powerglides for the local bracket racers. The short screen IS NOT from your transmission, it must have come from something else cleaned previously. Also, in the instructions that come with TransGo's Powerglide shift kit it says, "if this screen is used in your transmission, reinstall it"; that tells me not all Powerglides had that screen, and that perhaps it is'nt completely necessary.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-09-2009, 02:15 PM
Registered User
 
Last photo:
Join Date: Dec 2009
Location: Hernando, MS
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I have the factory 1964 manual and it does not show either screen. The smaller screen did come from this transmission, the parts washer was clean when I started. I'm thinking it could have been in the governor. I will take it back apart to check.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 12-09-2009, 06:10 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,057
Wiki Edits: 1659

Thanks: 314
Thanked 94 Times in 91 Posts
the long screen looks like an old skool t-400 governor screen... the short one looks like a C4 trans governor screen... wild guess on that.

The glides I have worked on over the years had no such screens in them..
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 12-10-2009, 11:25 AM
Registered User
 
Last photo:
Join Date: Dec 2009
Location: Hernando, MS
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I disassembled the governor and found where the small screen goes.
Attached Thumbnails
Click image for larger version

Name:	screen1.jpg
Views:	69
Size:	260.2 KB
ID:	42432   Click image for larger version

Name:	screen2.jpg
Views:	68
Size:	292.8 KB
ID:	42433  
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 12-11-2009, 10:01 AM
junior stocker's Avatar
Registered User
 
Join Date: Feb 2004
Location: Everett, Washington
Age: 62
Posts: 819
Wiki Edits: 0

Thanks: 0
Thanked 9 Times in 8 Posts
Just curoius, if you just disassembled the govenor, how'd the screen get out? I went back and looked at the books again, no mention of a govenor screen. It's probably something that's routinely left out at rebuild time. At least you found out where it goes.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 12-11-2009, 12:42 PM
Registered User
 
Last photo:
Join Date: Dec 2009
Location: Hernando, MS
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I had already had the governor apart, cleaned, reassembled, and reinstalled. It fell out while I was cleaning it. I just hate having left over parts!
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Powerglide electric shift/Trans brake valve body. junior stocker Transmission - Rearend 8 03-29-2011 05:13 PM
I lose compression w/ valve adjust drivehard Engine 6 11-23-2009 09:29 AM
master cylinder interchange runn141 Suspension - Brakes - Steering 7 05-03-2009 05:15 AM
Bad Valve Body? HawkZ28 Transmission - Rearend 2 02-26-2008 07:55 PM
Full Manual Valve Body TH-400 Chezelle Transmission - Rearend 3 06-13-2003 06:47 PM


All times are GMT -6. The time now is 06:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.