Need help, why engine is knocking. - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

View Poll Results: Is it possible that they sent the wrong part and caused the damage?
Yes. 0 0%
No. 1 100.00%
Voters: 1. You may not vote on this poll

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-25-2010, 09:45 PM
Eric63M's Avatar
Registered User
 

Last journal entry: Getting all the parts together for my LTX build
Last photo:
Join Date: Oct 2008
Location: Copperas Cove, Tx
Age: 27
Posts: 103
Wiki Edits: 0

Thanks: 1
Thanked 3 Times in 3 Posts
Need help, why engine is knocking.

Well title says it all, I have a nasty rod knock, now I'm sitting here thinking about what could have possibly caused it. I have a serous question here, if this is possible let me know, if you do not think its possible let me know. I'm setting up a poll and hoping for fast responses before I get a chance to call this transmission shop in the morning.

I replaced my transmission and engine @ 161900 miles, current reading is 193446 miles. Engine is a 360 Magnum (mopar), which is externally balanced w/ the flywheel/torque converter (weighted). The 318 Magnum is a internally balanced engine with no weights externally (naked flywheel/torque converter).

Is it possible that they sent me the wrong torque converter and that is what is causing my engine to go into self destruct mode?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-25-2010, 10:31 PM
Eric63M's Avatar
Registered User
 

Last journal entry: Getting all the parts together for my LTX build
Last photo:
Join Date: Oct 2008
Location: Copperas Cove, Tx
Age: 27
Posts: 103
Wiki Edits: 0

Thanks: 1
Thanked 3 Times in 3 Posts
Can't seem to find the edit button from my phone. The current mileage is 163446 not 193446. I guess I messed up that post in my rush. Current mileage on both is 2546 miles.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-26-2010, 03:11 AM
ericnova72's Avatar
More for Less Racer
 
Join Date: Jan 2007
Location: S.W. Lower Michigan
Age: 48
Posts: 9,897
Wiki Edits: 0

Thanks: 54
Thanked 631 Times in 561 Posts
It is possible, but would have shown up as a vibration the minute it was first started up after the swap.

Did you inspect the converter and flexplate for compatability?? Compare them to the old parts??

It would have been your responsibility to make sure parts were compatable/correct, not theirs, if you were the installer. If they installed, then it would be on them.

Unless you can confirm the converter and flexplate weighting is correct/incorrect, it is impossible to say this is definately the problem. Could be some other internal problem to the engine.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-26-2010, 08:23 AM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,670
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Make sure the flywheel bolts and torque converter bolts are tight. If one is loose it will sound like it's knocking. Did you build this engine? If so, did you check all the bearing clearances?
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SBC 350 superiority rebuttle...was:POWERED BY CHEVY, WRITTEN ON A FORD, (from 'Engine Oldsmolac911 Hotrodders' Lounge 50 01-12-2011 11:00 PM
Buick 430 Engine 70LEBUICK Engine 5 02-24-2010 10:57 PM
Build for Hp or Torque? Venturat Engine 76 09-23-2008 11:22 AM
Why high RPM's on the oval tack? steveyb4342 Engine 25 05-23-2007 08:50 AM
engine developed knocking sound sune Engine 6 09-06-2004 03:40 PM


All times are GMT -6. The time now is 12:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.