Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   Need suggestions, randomly dying 02 Camaro 3800 DBW (http://www.hotrodders.com/forum/need-suggestions-randomly-dying-02-camaro-3800-dbw-206011.html)

Speedyoldtruckdotcom 09-23-2011 06:02 PM

Need suggestions, randomly dying 02 Camaro 3800 DBW
 
Longtime lurker, rare poster but I've got a problem I can't seem to figure out and don't want to throw parts at it without a clue...

Friend of mine has an 2002 Camaro 3800 series II drive-by-wire. Recently replaced plugs (Factory recommended ac delcos), wires, cam sensor, air filter, cleaned MAF and replaced fuel filter. Car randomly dies going down road, no check engine light either when it dies or normal running. My friend took it to a shop that wanted $900 to do fuel pump, but I don't believe the problem is fuel pump as it has good fuel pressure running and during/after it stalls out. Sometimes I'm able to keep it running by flooring the pedal and it chugs a bit, then revs out of a stall, and sometimes it will just die anyways. This happens basically at random, either going down road or sitting idling, but no more than 15 minutes go by without it happening. I tried pulling vac line off of fuel pressure regulator with engine running and it doesn't reek of gas or look moist even after several minutes of running. Car will always restart after dying, but sometimes I need to floor pedal in order for it to restart easily which makes me suspect ignition more than fuel as the reason its dying

Car idles smoothly, check engine light does work (at bulb check it turns on, then shuts off when engine is started), and has no stored or current codes. I tried pulling ICM and had O'reillys test it and it came back fine, I don't want to throw any number of expensive parts at the car without some good reason to believe that is the problem, but at this point I'm suspecting ECM or ICM, but both of those are expensive and I don't want to pick wrong as we're working with a limited budget here. Any bright ideas, or ideas as to how I can be sure which is causing the problem? I have a code reader but not a fancy scanner, though I could probably borrow one.

roysaric 09-23-2011 06:53 PM

This sounds like a problem my friend had and it ended up being the ignition. dont know why they go out but they do. Id try it out.

LATECH 09-24-2011 04:48 PM

put aa fuel pressure gauge on it and a test indicator light to the fuel pump power lead. Then drive it and watch while the problem occurs.If the light stays on and the pressure falls of along with performance then you have a fuel pump problem.If the power goes out to the pump and pressure drops off, then you have an electrical issue.Get busy. :D


All times are GMT -6. The time now is 06:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.