Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Need ya'lls opinions on SBC heads
View Single Post
  #31 (permalink)  
Old 11-13-2012, 07:38 AM
Camaro_Nut2001's Avatar
Camaro_Nut2001 Camaro_Nut2001 is offline
Drag Racing Lover
 

Last journal entry: '68 Impala Project
Last photo:
Join Date: May 2009
Location: Mascot, TN.
Age: 46
Posts: 143
Wiki Edits: 0

Thanks: 86
Thanked 2 Times in 2 Posts
Well, it's been a few days but I got the Impala back together, new cam broke in etc... I didn't go back with the Tunnel Ram, due to the Impala having to be outside while I pull the motor in the S10, I went with an old intake and carb I had put back, a Stealth and 670 Street Avenger. I figured the motor would really have some bottem end but I swear, I think it ran better with the Tunnel Ram and two 1850's. I do think the motor is running on the lean side with the 670. I have the timing turned down just a tad and the 670 adjusted rich as I can untill I get a 4779 built for it. I have the kit but I want to get this motor out first, lol. Also, I bought a pair of Magnaflow's #10416 as I read they flow alot better than Flowmaster, which is what's on the Impala now, but haven't had time to have exhaust put on yet. I do have the S10 in the garage and plan on starting on it today.
On a side note, I saw a post where Tech Inspector was talking about going an 1/8th of a turn after zero lash on valve adjustment but the OP was talking about his hyd. roller lifters. I wonder if Tech was meaning an 1/8th turn on all hyd. lifters or just rollers. I may post back on that posting and ask, unless he see's this, lol. Anyway, I will post pictures of the motor when I get it out and cleaned up.
Reply With Quote