Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - Need your thoughts.. Engine trouble
View Single Post
  #43 (permalink)  
Old 07-20-2008, 03:24 PM
camaro freak camaro freak is offline
Registered User
 
Last photo:
Join Date: Mar 2006
Location: Ohio
Posts: 232
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
We Got It.....

Awesome plug info link... Ok folks we got it! I tested the distributor and wires and all was good! I built a spark plug tester using a 24 volt spark ingintor from a furnace and the transformer so I could test each spark plug. As I went from plug to plug I noticed that each spark looked weak. The sparks were orange in color and not like the nice blue spark that came from the wire when I tested it. We got to plug 8 and guess what? NO spark!!! None at all!!! So we made a trip to Advance and what the heck lets grab those 5 year warranty E3 plugs at $7 each and see what happens! Well, after laying a patch 25 feet long and burying the speedo I would say we found our problem! I plan to let the motor cool some and then read a few plugs and adjust if necessary. I do however plan to stay with a Holley. I want a 750 double pumper HP carb, I may consider an 850 double pumper after reading the test results from the 383 build that Chevy High Perf magazine got! If someone has a good new or like new Holley like I want, drop me a note in the next few hours, well by 9 pm est and maybe we can work out a deal. The BG carb I have is like new, honestly, we have only put about 100 miles on it. We changed the PV and put reusable blue gaskets on it and that is all we did outside of adjusting it. After 9 pm est it will be on eBay! Thanks to all for the help!!! I hope this thread is helpful to someone else!
Reply With Quote