Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - new build feels under powered
View Single Post
  #26 (permalink)  
Old 07-22-2012, 03:35 PM
F-BIRD'88's Avatar
F-BIRD'88 F-BIRD'88 is online now
Yada Yada Yada
 
Last photo:
Join Date: Oct 2005
Location: Ontario, Canada
Posts: 9,541
Wiki Edits: 0

Thanks: 3
Thanked 331 Times in 328 Posts
Things will get very complicated if when you lean on it too hard with just pump gas.

If you want to play:
Get some 110+ unleaded gas so you can up the boost and timing safely and see how it should be running.

Then detune it again for pump gas.

The car wil run much better with that big cam if you jsut lock out the spark advance 30 intial and 30 WOT under boost. The big cam will love intiial timing. The idle, low end , throttle response and boost response will improve. It will idle much cleaner too.

Big WOT timing, under boost requires octane or charge cooling . The heads are dead. Quit fuggin around and fix the heads.
Then you will see how a turbo motor really runs. Turbo motors need head flow too.
If you cannot afford race heads, max port the heads you got, yourself.

Build the knock detector/listener and use it.
if you can't afford heads you also cannot afford to smoke this motor...... right

Take a valve cover off and ID the casting number

You got a huge cam (for a turbo motor) and heads that suck. just adding boost will not help it, much.

Do you have a boost retard box?

Last edited by F-BIRD'88; 07-22-2012 at 03:46 PM.
Reply With Quote