Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - new build feels under powered
View Single Post
  #66 (permalink)  
Old 10-09-2012, 06:26 PM
Project89's Avatar
Project89 Project89 is offline
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 988
Wiki Edits: 0

Thanks: 12
Thanked 35 Times in 32 Posts
Quote:
Originally Posted by F-BIRD'88 View Post



I bet that 9sec firebird is using a efficient air to water intercooler, cooling down the charge air temp
to BELOW AMBIENT temp.

You say you can show it. Post a link where it is discussed in a forum or other web site BY THE OWNER OF THE CAR.
I know its possible and I know what it takes to achieve that level of performance.

Yup the twin Buick GM turbos work very well. (TWIN being the key word.)
sorry i never even saw this reply
heads have 1.72 intake valves
Quote:
The block and heads came out of a 80 chev pickup(not original motor) and near as we can tell, it has 150k on it. Has dogcrap 991 small valve truck heads with 76cc chambers and 1.72 intake and 1.5 exh. valves. Should be 8.6 to 1 with 4 valve relief flat tops that are .022 in the hole and a .038 gasket.
no water to air cooler here here is the thread
http://www.theturboforums.com/smf/th...art-2-to-come/

and if u dont want to take 3 years to read all couple hundred pages or so

Quote:
For those of you who dont want to go blind reading all this, the old used up motor was pulled out intact and running perfectly after going 9.37@150! Best power number was 738 whp @ 25 psi and a 75 shot of NOS. Ring gap ended being .090 on the top ring when i finally pulled a piston out of the hole. Yikes! :doh:

Last edited by Project89; 10-09-2012 at 06:49 PM.
Reply With Quote