new build feels under powered - Page 6 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #76 (permalink)  
Old 10-10-2012, 07:25 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 1,003
Wiki Edits: 0

Thanks: 12
Thanked 37 Times in 34 Posts
Quote:
Originally Posted by Pupsvette76 View Post
Ok just an update I messed around with the fi today and got it pretty dialed in didn't do much tuning just kinda changing some preset settings and it will now hot like 5300 still low since the rev limiter is at 7k... But anyway I went into my log files and my afr at WOT will hit 9 for like a millisecond and then rebound and search for the target afr which is about 12 at WOT fuel pressure never drops off lowest number I saw was like 42 and I have it set to 45 boost refernced
theres ur problem now with a wideband u have to be carefull if the motor is going way lean it can give a false rich reading on the wideband.

same goes for the other way around.

so go into ur ve map and take away a lil fuel in the area were its going into 9afrs and see if it helps , if u take away some fuel and it gets worse then u know its a false rich reading and u have to add fuel instead

what fuel injection system did u say u were using, if u need it i canprolly lend u a hand getting the thing tuned and looking at the datalogs

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #77 (permalink)  
Old 10-11-2012, 08:49 AM
Registered User
 
Join Date: Oct 2011
Location: Mo
Posts: 148
Wiki Edits: 0

Thanks: 0
Thanked 6 Times in 6 Posts
I think you need a cam with zero or negative overlap. As rpm builds the pressure in your exhaust increases to the point that it's higher than the intake boost. When the intake opens during overlap it's reversing flow because of the high pressure inside the cylinder. Another thing to think about is increasing the strength of your valvesprings because of the greatly increased pressures that their dealing with. The World Products heads that you mentioned would be a good choice, the 74cc heads that Engine Quest makes for IMCA racers would work well too.
Reply With Quote Quick reply to this message
  #78 (permalink)  
Old 10-11-2012, 11:18 AM
Pupsvette76's Avatar
Registered User
 

Last journal entry: no spark and fuel pump issue
Join Date: May 2009
Location: smithtown
Posts: 467
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I've been rseaserchng the afr 1050 Heads the have the big chamber I need large intake runner the are CBC ported and my friend at my speed shop can make me a good deal on them
Reply With Quote Quick reply to this message
  #79 (permalink)  
Old 10-11-2012, 12:39 PM
Registered User
 
Last photo:
Join Date: Jul 2004
Location: At Speed
Age: 51
Posts: 1,392
Wiki Edits: 0

Thanks: 2
Thanked 41 Times in 39 Posts
After spending some hours with a PowerjectionIII the last few days, I would suggest you spend some tuning it as it is not nearly as self-tuning as they claim. Also, you have to go their website and read through the forum cause there is some stuff posted there that is absolutely necessary to know that is not in the instructions.
Reply With Quote Quick reply to this message
  #80 (permalink)  
Old 10-11-2012, 01:05 PM
Pupsvette76's Avatar
Registered User
 

Last journal entry: no spark and fuel pump issue
Join Date: May 2009
Location: smithtown
Posts: 467
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Anything in particular. So I have an idea what I'm looking for
Reply With Quote Quick reply to this message
  #81 (permalink)  
Old 10-11-2012, 06:51 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 1,003
Wiki Edits: 0

Thanks: 12
Thanked 37 Times in 34 Posts
Quote:
Originally Posted by Pupsvette76 View Post
Anything in particular. So I have an idea what I'm looking for
post ur tune ur running up on here and ill take a look at it and see if anything obvious sticks out at me as being wrong

if u cant post the tune file son here ( dont know if the board will allow u to attacjh it ) post it on mediafire and post the download link
Reply With Quote Quick reply to this message
  #82 (permalink)  
Old 10-12-2012, 01:30 PM
Pupsvette76's Avatar
Registered User
 

Last journal entry: no spark and fuel pump issue
Join Date: May 2009
Location: smithtown
Posts: 467
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I'm not able to upload my file it will not allow me
Reply With Quote Quick reply to this message
  #83 (permalink)  
Old 10-12-2012, 05:54 PM
Project89's Avatar
Registered User
 
Last photo:
Join Date: Oct 2011
Location: utah
Posts: 1,003
Wiki Edits: 0

Thanks: 12
Thanked 37 Times in 34 Posts
Quote:
Originally Posted by Pupsvette76 View Post
I'm not able to upload my file it will not allow me
upload it to mediafire.com its free and it will give u a link u can post here so i can download it
Reply With Quote Quick reply to this message

Tags
355, chevy

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
4L60E when in rev feels like brakes are on honeyhush Transmission - Rearend 1 07-15-2012 09:41 AM
Air powered or battery powered nailer? HotRodMan Garage - Tools 4 07-26-2010 08:09 AM
5500rpm feels like the car has a governor 72highboy390 Engine 1 07-09-2010 10:09 PM
Feels like i am driving a tractor... mariolamore Engine 14 10-14-2009 03:12 PM
My engine feels like its missing Camaro31 Engine 9 09-30-2008 02:27 AM


All times are GMT -6. The time now is 01:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.