new cam and heads!!for 92 mustang gt 5.0 aod - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-16-2002, 07:09 PM
Registered User
 
Join Date: Apr 2002
Location: burbank
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post new cam and heads!!for 92 mustang gt 5.0 aod

here we go!i just had my motor rebuilt,it has about 700 miles on it i put a e303cam and gt40 turbo swirl heads 54cc. now here is the problem!its seems to have a pretty rough idle i know it was going to be a little different but from what i was told it wouldnt be that eratic its very lumpy also does not seem to have much of the line but does have alot more get up and go when you get up in the rpm.or is it getting enough gas?fuel presure regulator mabe? if any one has some input for me i would geatly appreciate it.im just breaking in to this hobby.thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-17-2002, 07:41 AM
mustang66maniac's Avatar
Ford Freak
 
Last photo:
Join Date: Feb 2002
Location: Rockville, MD
Age: 30
Posts: 676
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Is it a mass air or speed density system? I heard speed density systems dont adapt as well to mods as mass air. Thats the only thing i can think of. I have an E303 cam also and it runs fine with a lot of low end torque.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-17-2002, 07:46 AM
mustang66maniac's Avatar
Ford Freak
 
Last photo:
Join Date: Feb 2002
Location: Rockville, MD
Age: 30
Posts: 676
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Nevermind, I didnt see the "92" part, so i guess it is mass air. Um, are you sure you got the cam timing right? Maybe you put it in retarded, that would explain the bad idle and torque but more upper RPM power. I dont see why the fuel system would need mods, if it was fine before, i dont think you should have to change it, besides if you werent getting enough fuel i would think you would feel it in the upper rpms not the lower rpms.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 09:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.