new front brakes sticky - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-02-2004, 06:21 PM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
new front brakes sticky

i just put on some new rotors and brake pads on the front of my 82 grand prix. no fluid or anything in the brakes. the wheel is hard to turn. is that normal?? will it fix itself once i put fluid in it and start using the car??

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-02-2004, 06:24 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 261 Times in 213 Posts
Are you sure that you have the caliper back on square?

Did you push the piston all the way back into the caliper?
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-02-2004, 07:53 PM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
ya i pushed the piston back, unless it moved back out or somthing... i dont think so, no brake lines even hooked up. how do u mean put the caliper back on sqaure?

how tight should i be putting thos allen key bolts that hold the calipers in place?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-02-2004, 08:11 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 261 Times in 213 Posts
If you pushed the piston all the way in, there should be a little space between the pads and rotor. This closes up once you step on the pedal the 1st time.

Is both sides the same?...maybe you have the wrong pads, but I don't think so, if they fit.

By square, I mean that they are straight....nothing is bent, is it?
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-02-2004, 09:06 PM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
nothing is bent that i can tell.

on the caliper where i put the long bolt threw there is like little things that i had to push out to fit the caliper on. they are like a bushing inside the hole. when moving those it like adjusts the caliper i think. i couldn't get the caliper over the bolt hole on the spindle without moving them over a bit. did i do something wrong there?

i put some brake fluid in and pumped the brakes a few times and it got worse... can barely turn the wheel
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 05-02-2004, 09:09 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 261 Times in 213 Posts
Yeah, you did the right thing moving those spacers..............Put some fluid in them, bleed 'em and try it. If they overheat, they are too tight. If not, they should be OK.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 05-03-2004, 01:27 AM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
ok thanks

for changing out the rear drum brakes what tools do i need to buy? i need to change the pads, drums and wheel cylinders. looks very complicated with all thos springs and *****.

once i got the rear brakes on ill bleed all the brakes then hopfully the front wont stick then...
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 05-03-2004, 05:27 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 261 Times in 213 Posts
You need a spring tool, pliers and whatever size socket that the bolts on the cylinder are. The cylinders are a real pain in the *ss to change. Actually, there was a recall on these cylinders and backing plates, they kept rusting out.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 05-04-2004, 10:44 PM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
ok well im working on the rear brakes right now and i got the passenger side all apart and finnally got the wheel cyl on after like a hour trying to get the clip in. the wheel cyl feels a bit loose and if i pull on it enough it just pops off. i cant imagine that is good. all that holds it on is just 1 circle clip thing on the back side.
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 05-04-2004, 10:47 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 261 Times in 213 Posts
Yeah, they are real crap................bend the tangs on the clip out a bit more to grip the cylinder better. You don't want them falling out.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 05-05-2004, 03:05 AM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
ok i got thew new pads and wheel cyls installed on the rear fine now.

i installed the rotors and wheels and put the parking brake on to test and with both rear wheels off the ground and tranny in neutral. the drivers side i cannot turn forward at all and i can barely turn it backwards but on the passenger side i can turn it forward with not much effort and turning it backwards it grabs a bit. is that normal or do i need to adjust something to get the best out of the E-brake.

the drums that were on the back of my car i took off earlier today and they were rusted the F*ck out so i just junked them and went and got another set i had. took them to auto value and he measured and said they could be machined 1 more time but since theres not to much more on them they could warp or somthing and recommends just reusing them they way they are, scuff them up and use them 1 more time. should i use them or fork out the money on some cheapy Jasper drums from crappy tire, like $25 a peice i think? not shure though
Reply With Quote Quick reply to this message
  #12 (permalink)  
Old 05-05-2004, 05:30 AM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,898
Wiki Edits: 5

Thanks: 20
Thanked 261 Times in 213 Posts
You need to adjust the shoes so that they are just slightly rubbing on the drums.

Clean up the drums that you have.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #13 (permalink)  
Old 05-05-2004, 03:33 PM
montea's Avatar
tryn to learn
 
Last photo:
Join Date: Dec 2003
Location: Alberta
Posts: 844
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
OK thanks alot poncho, you helped me out alot
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.