Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - New Transmission Leaking
View Single Post
  #1 (permalink)  
Old 07-27-2009, 08:10 AM
SmokeShow01's Avatar
SmokeShow01 SmokeShow01 is offline
Registered User
 
Join Date: May 2009
Location: Calgary Alberta
Age: 48
Posts: 14
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
New Transmission Leaking

I just drove home with my newly installed ZZ4 350 Crate Engine mated to a TCI SSF 700R4 with a 2500 lock-up stall converter, 4.11 Rear Gears. I drove approximately 160 km (100 miles) on the hiway 110 km/hr- spirts to 140 km/hr (65mph-spirts to 85mph) and I noted some smoke coming out of one of the tailpipes. Concerned of course, but it was very light coloured, almost vapour like, continued to drive vehichle seamingly working well. The Oil pressure gage gives me a highish reading, not sure if it is functioning properly, the Vehicle the engine is in is a 76' GMC Pick-up. The temp outside was 31C or 87.8F dry and hot. Keeping an eye on everything, I touched the bottom of the tranny looked at my finger and saw, Cherry Flavoured Cough Medicine...I am like...oh oh....whats going on here...

I clean up and wipe down all surfaces, I noted the blow back of the oil over the exhaust system, mostly on one side, hence the smoke I saw coming out or, seemingly out of the exhaust pipe, now realizing that it was the tranny oil burning on the hot surface of the exhaust pipe on the one side, at least now I don't have to get any undercoating done for rust.

I checked fluid levels, and Tranny looks highish, I mean, is it possible to put too much Tranny fluid in a Tranny? The level is on the Top Line of where it says Engine Hot, this is when the Vehicle sat over night and cool in the morning.

Looks like the Oil is coming from the drivers side where the transmission meets the engine - lower left front corner of Tranny. Could it be the Torque Converter? Any thoughts from anyone?
The vehicle still drives, did seem to be switching from 3rd to OD and back again a few times...
Vehicle still seems to have lots of power, I am just afraid to push it at all, don't want to do any damage, I am going to bring it to a shop today, just looking for some input, thanks guys.

Last edited by SmokeShow01; 07-27-2009 at 08:21 AM.
Reply With Quote