Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> ford 5.0 block
User Name
Password
lost password?   |   register now

Thread: ford 5.0 block Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-31-2008 08:12 PM
GypsyR "Knock sensor". Not really used until 1992 and up, which would make your block "knock sensor ready".
It's very annoying to swap an otherwise identical 1991 5.0 into a 1993 truck and THEN discover the earlier engine wasn't drilled and tapped for the knock sensor. Not that I would know anything about that sort of thing.
12-31-2008 02:03 PM
ScoTFrenzel Yesterday we pulled an 88 5.0 HO out and I took a good look at the block.

On the passenger side rear, inboard of the upper most bellhousing bolt and inboard of the bellhousing ring is a large rounded cast in boss about the size of a small chicken egg. This is directly below the flat machined surface.
NO hole.
It appears this cast in boss is there doing nothing,
so maybe there is some instance that they might tap a hole into it for hoisting as suggested in a previous post.

Never really noticed the boss before, and never have seen any with a hole.

I personally have a 90 HO fuelie and a 90 TownCar and neither have a hole.

I might suggest that it is a place for a knock sensor since the 351W engine used in my 95 EddieBauer Bronco had a knock sensor in this same location which I had to replace.
12-28-2008 08:03 AM
woodz428 You might post a pic. As well as the casting number to verify the year. The only thing in the back of the block that leads directly to the oil galley is under the manifold and you sound as it it is located behind it. Behind it would have to lead to the back of the engine where the flywheel is, not the oil galley. Some 5.0 blocks, had timing holes in that area for assembly line timing. Again, a pic and casting number would go well in determining what you are asking about.
12-28-2008 01:12 AM
timothale
I haven't looked

Ford has sometimes used threaded holes to install lift rings that are later removed on the assembly line
12-23-2008 05:27 PM
AngliaBob
ford 5.0 block

I have a 91 5.0.
Can anyone tell me, what is the 1/2 NC hole, in the rear/top/pass side on the horizontal part of the deck , behind the intake?
It appears it may be connected to the passenger side cam oil galley.

It is in approximately the same position where the oil sender would go, in a Chevy.
But, the Ford oil sender location is between the fuel pump and block on the drivers side.

Any help is appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.