Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> chevy 383- timing and carb advise
User Name
Password
lost password?   |   register now

Thread: chevy 383- timing and carb advise Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-30-2009 05:25 PM
RowShan Just to follow up on this,
I tried the timing light again and it doesn't seem to be moving even half as much. jumps maybe a degree or 2 but not half as bad now... hmm maybe the dizzy was too loose the first time?
it seems as if the normal Alan type screw that goes in the top of the rocker was missing or something and the previous owner put a bolt in there that has a 9/16" head on it, maybe this (bolt) isn't holding the rocker where it should be?? Letting it back out some and causing the tapp tapp tick . Anyways I have a friend coming over tomorrow that's a GM tech hopefully he can get this all straightened out... thanks to those who have replied and I will give updates as I figure more out.
Thanks
09-30-2009 04:51 PM
cobalt327
Quote:
Originally Posted by RowShan
Ok so last night, I adjusted the timing, it seemed like when I went up to around 34 it seems ok, I noticed though that the mark on the harmonic balancer was pretty irratic! It seemed to move back and forth almost 5 degrees...
This could be due to the mechanical advance springs being right at the point that the engine RPM is causing advance to begin. Try either a stiffer spring on one side or lowering the idle speed to see if the timing stabilizes.
09-30-2009 02:26 PM
RowShan Just took the valve covers off to see if noticed anything terribly wrong... all look ok except on the passenger side roller rockers there is a damn bolt screwed into the top where you would put like an allen wrench?? I think? Its only on one of the rockers and I cannot figure out why??
09-30-2009 08:16 AM
RowShan Ok so last night, I adjusted the timing, it seemed like when I went up to around 34 it seems ok, I noticed though that the mark on the harmonic balancer was pretty irratic! It seemed to move back and forth almost 5 degrees... What the heck is that from? Another thing i noticed when giving it some gas it sounded responsive but after revving like when its coming back to idle I notice a tapping ticking noise... could this be from the timing? or are we taliking valves? or Rod bearings? hope not! Rod bearings is why I got rid of my 350 a few months back! It only makes the noise when its coming off the rev, not while its going up?? This has me stuck! Any help please??
09-29-2009 05:11 PM
RowShan Anyone have any other opinions.. or on my other questions?
Thanks
09-29-2009 04:01 PM
ap72 stock jets, spring, and rods in the carb to start with (maybe a hair richer on the small end of the metering rods to get started) and 14 degrees initial 34 degrees total timing.
09-29-2009 03:55 PM
RowShan
chevy 383- timing and carb advise/Now irratic timing mark! and ticking!! oh no!

Hello, Hopefully someone can help lead me in the right direction.. I have been reading all kinds of message boards for a few days now and cannot seem to get an answer.. Heres my issues.
I bought a 383 stroker engine from a lady whos husband went to jail.. therefore she had no clue what it has in it, Friends that knew him said only that is it 383 , has 400 crank, mild to med cam, stock heads, with headers, and edelbrock 1405 600cfm carb. The engine had never been on the road, it was just dropped in his project car before he went to jail, Anyways a few buddy's and myself pulled the engine for my pickup truck that I have, we got it running and has been doing ok, but does not have the power I think it should, not much more than the stock 350 that was in my truck.
The carb is still in stock form, no adjustments except the idle mixture screws a few turns out which seems right. I also just tried swithching the dizzy's vac advance from the timed vac port on the carb to the manifold vac port. The idle went up some and i lowered it with the adjust screw on the carb throttle linkage. Haven't got to test drive it yet, (its not street legal) more for off roading.
I'm wondering if someone can give me advise on what to set the timing at for a good starting point? and what to look for if i turn the dist cap too far one way or the other while fine tuning it. Inital timing and final... Also any recommendations for the carb 1405 calibration? jets, Metering rods, and such?
Any help would be greatly appreciated.. Please.
Thanks so much in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.