Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools> Rebuilding Power Washer Wand
User Name
Password
lost password?   |   register now

Thread: Rebuilding Power Washer Wand Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-10-2010 09:06 AM
snorulz Thanks, I will look into that. Nice to know what the washer thing really is.
09-10-2010 08:57 AM
35WINDOW What you are describing in terms of the "seal thing" is probably a back-up washer-it stabilizes the o-ring so that it can't deform out of the o-ring groove. I believe the reason you can't shut off the flow is that the o-rings are deforming and won't allow the valve to return to home-

Go to a Hydraulic Repair shop or a Construction or Agricultural Dealer-they are a common item in those Industries-
09-10-2010 07:35 AM
snorulz thanks guys, I gave it a try and the wand is sealed right up. The only problem I have now is that the wand will not shut off completely. There is always a slow stream of water coming through the tip. Any ideas on how to get this stopped?
09-09-2010 08:31 PM
SuthnCustoms I've replaced those O-rings in pressure washers that people sold for practictly nothing because they leaked and lost pressure and resold for a hefty price,about 10.00 at the most at the local auto store for a bag of different sized O-rings and the things work like new.
09-09-2010 07:38 PM
russlaferrera It is worth a try. They do make a High temp grease for steam valves that is available at a plumbing supply
09-08-2010 07:13 AM
snorulz
Rebuilding Power Washer Wand

I have an Excel Pressure washer with a 5hp Honda engine on it and a junk oil less pump. I ordered a much better oiled pump with a thermo relief valve so that should take care of the pump issue. The other issue I have with it is water leaks out of the wand handle where the trigger is. I can buy a new wand for $40 but I would rather just fix mine. I took it apart and right away found where the leak was.

There is a brass collar and a brass fitting that goes into the collar. The fitting slides in the collar turning on and off the water. There is an o-ring and a brown looking seal thing (not really sure what it is exactly) that go into the same groove (side by side) on the fitting. Both o-ring and seal thing are very worn on one side. I was thinking of just replacing both with two o-rings. Do you think this will work?

My last question is what should I use to lubricate the seals? I was thinking of using high temp axle grease but wondered if there was something better?

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.