Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior> First thing I have ever painted
User Name
Password
lost password?   |   register now

Thread: First thing I have ever painted Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-13-2010 04:50 PM
milo I would say to buy a camera so you could post pictures of your project instead of wasting dough on wax and grease spreaders
12-11-2010 01:43 PM
Spectre32 I used laqour thinner to clean the parts but they all came from ford electrocoated. I used 400 wet after I srpayed the primer. I did do about two coats. I do however need to invest in some good wax remover/degreaser.
12-10-2010 05:25 PM
50ford
paint

you should have sanded your primer with 400 wet sand or 450 and gone 2 rounds each coat on the primer wait about 15 min between coats then let dry for about an hour then sand and you should allways use a degreaser befor you sray anything i like dupounts 3919s
12-06-2010 12:08 PM
Spectre32
First thing I have ever painted

Well over the past week I went up to my buddy's shop and sprayed a bumper for my truck. Its an 03 F250 and my buddy backed up into me so I ended up buying a whole new front metal and plastic trim cover. Both needed to be sprayed so I have always wanted to learn/do auto painting so I decided to take a stab at it. I donít have any real good pictures as I took a few with my phone but they donít really do it justice(for better or for worse). What Iím looking for is some input/critique on my methodology. Here how the sequence of events played out:

Took the new bumper and plastic trim piece from Ford and used some fine scotch brite to scuff up both pieces. I used a soapy water mix on the plastic(I used Tide) to pre-clean it and then clean it after scuffing. I hosed it off and towel/air dried it. On the metal I used some laqour thinner. After this I sprayed the inside and outside with primer. I sprayed about 2 coats to of this on both sides of the metal part and just on the front part of the plastic trim. Once dried. I sprayed the back side with base coat and clear of both pieces and edged the plastic/metal interface. After propper drying time I assembled both pieces and preceded to wet sand the front. I used 400 grit and sanded everything I could with one of those flexible foam backing pads. I started out on the plastic first as I have never wetsanded anything bfore and if I burned through an edge...it was plastic and not bare metal. I cleaned up everything and laid down two coats of base coat. After flashing/tacking I sprayed the clear down. The I used the straight clear and the hardener but apparently I was going to slow...so I had to throw a bit of a reducer in it. I laid down three coats of clear and let dry. Overall it looks pretty good, however A errant throw of a bucket has set me up to redo the basecoat and clear....plus some possible body filler work(its all int he plastic...so I 'm not sure what I'm going to do yet). I didnít have any real problems outside of the fact that I had a fisheye that laid down after applying more base coat(on the plastic) and after the first layer of clear the gun started to "act funny". Apparently whoever used the gun before me used his clear gun for base coat and I got some white spec's in the 2nd layer of clear. I had a little bit of orange peel but apparently that happens when laying down a few layers of clear...plus I'm sure my technique was part of it. After the bucket toss I'm just going to DA is back down and respray........

As for materials I was used sherwin williams 4th demsion basecoat and some Xtreme Clear and 2K Epoxy Primer/Filler/Sealer. Its a daily driver so nothing to crazy. I was looking for cost effectiveness.

One of my main questions is this... Once I redo all of this... I was wondering what would be approproaite sanding wise for my application. As I said its a daily driver and not a show car by anymeans. I was going to use some 800 and then some 1500 and let the buffer take it from there....

Thanks for any input.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.