Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Going EFI on 406 SBC questions
User Name
Password
lost password?   |   register now

Thread: Going EFI on 406 SBC questions Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-29-2011 11:12 AM
LanceM Yes I'm starting to lean that way, a mornings researching is showing that MP will probably be way more trouble than it's worth for my goals. I've already have an 0411 ecm and harness to work from, the one thing I haven't been able to find is whether or not the reluctor from a vortec will fit a 70's crank.. If it will then I'm good to go.
01-29-2011 10:55 AM
matt167 Your best bet is using an entire Vortech EFI setup.. you will need to mix and match some wiring from the Vortech donor truck, but it is doable.. you could actually swap the dash and all wiring right in with little effort
01-29-2011 07:49 AM
LanceM
Going EFI on 406 SBC questions

I have aquired a SBC 400 .030 over that I want to put in my 92 C1500. For personal reasons I want to go multiport EFI and have a couple of questions that I'm sure somebody here knows right off.

I will need both crank and cam sensors, I believe I can easily get cam sensor by using a vortec distributor, or even the distributor I currently have in my TBI engine, correct?

For a crank sensor I can use the reluctor from a Vortec engine along with the front cover and a external balanced dampner for the same, correct?

I'm trying to mix and match parts from the 70's with tech from the 90's without spending a million dollars... am I even crazy for trying?

Thanks,
Lance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.