Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> Carter / Edelbrock fuel pump & carb problems
User Name
Password
lost password?   |   register now

Thread: Carter / Edelbrock fuel pump & carb problems Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-16-2012 07:32 PM
67Mustang Al.
Quote:
Originally Posted by Irelands child
Al - it's actually gotten to around 30 here as well -- but *F

Edelbrock may have been off today - national "holiday", Martin Luther King Day so many have taken it for an R&R.

More later - I have a pocket door in my house apart

Dave W
Good luck with that door. So i may even hear from Edelbrock.
01-16-2012 06:42 PM
Irelands child
Quote:
Originally Posted by 67Mustang Al.
Hi Dave
At this point there has been no response from Edelbrock after 6 pics +email to Edelbrock@edelbrock.com. I dont think i will hold my breath on that one.
So its an early Ford in the previous pic. It got my attention when i saw the induction system also. Having a belt drive off the end tells the story. Early charger by the look of the casting.
Taxes here are also ever increasing as my working wife tells me. We have a similar tale here in our household Dave.
I recall guys her at the local Bearing Manufacturer travelled globally selling our product including trips to Cleveland and the Clevite Manufacturing facility. One of the guys who used to do that now sells real estate and sails his yacht.
But he doesnt have a classic Mustang.
P.S Going to be around 30 here today, not minus 30 as one may find in upstate NY.
Cheers
suthen AL.
Al - it's actually gotten to around 30 here as well -- but *F

Edelbrock may have been off today - national "holiday", Martin Luther King Day so many have taken it for an R&R.

More later - I have a pocket door in my house apart

Dave W
01-16-2012 04:35 PM
67Mustang Al.
Ford Power.

Hi Dave
At this point there has been no response from Edelbrock after 6 pics +email to Edelbrock@edelbrock.com. I dont think i will hold my breath on that one.
So its an early Ford in the previous pic. It got my attention when i saw the induction system also. Having a belt drive off the end tells the story. Early charger by the look of the casting.
Taxes here are also ever increasing as my working wife tells me. We have a similar tale here in our household Dave.
I recall guys her at the local Bearing Manufacturer travelled globally selling our product including trips to Cleveland and the Clevite Manufacturing facility. One of the guys who used to do that now sells real estate and sails his yacht.
But he doesnt have a classic Mustang.
P.S Going to be around 30 here today, not minus 30 as one may find in upstate NY.
Cheers
suthen AL.
01-16-2012 09:47 AM
Irelands child
Quote:
Originally Posted by 67Mustang Al.
HI Dave
Edelbrock will have some of the pump pic mods shortly to file in their deleted items no doubt. If this fix lasts , well and good, if not i found a carter pump on Ebay aus for $55.
What an interesting and rewarding career.(Electrical Engineer ?) My son is a ME (nav Architect) Looks like you would have been globe trotting quite a bit. your expertise would still be sought after no doubt. A small company here in Aus has developed a small natural gas turbine power plant that is a free standing unit and produces enough power for a domestic house with excess back into the grid .
That is shivering weather there Dave. Brrrrrr.
Pics are from yesterday's USA show. It is an early supercharged early model of some sort.
Cheers
Al
Hi Al,
Nope, not EE, ME. I'm just barely beyond knowing what happens electrically when you plug an appliance into a receptacle.

Good price on that fuel pump. Looks like the Aus dollar is near par with the USD. Always good to have a spare.

As far as going back to work in the US economy these days is near zilch - plus the tax implications make it worse. My wife has a PT job with our local town and makes virtually nothing, but it does impact our taxes and her social security payments. And working outside the country and making THE BIG bucks is negated by the amount of time you need to stay away to keep those bucks, again taxwise, plus it just isn't fun to travel in way off countries any longer.

That photo is a '35 Ford with an 8BA, '49-'53 Flathead power. The supercharger, or whatever it is - sure an interesting induction system.

Oh and the temp - still a bit chilly

Dave W
01-15-2012 04:45 PM
67Mustang Al.
Chills.

HI Dave
Edelbrock will have some of the pump pic mods shortly to file in their deleted items no doubt. If this fix lasts , well and good, if not i found a carter pump on Ebay aus for $55.
What an interesting and rewarding career.(Electrical Engineer ?) My son is a ME (nav Architect) Looks like you would have been globe trotting quite a bit. your expertise would still be sought after no doubt. A small company here in Aus has developed a small natural gas turbine power plant that is a free standing unit and produces enough power for a domestic house with excess back into the grid .
That is shivering weather there Dave. Brrrrrr.
Pics are from yesterday's USA show. It is an early supercharged early model of some sort.
Cheers
Al
01-15-2012 07:07 AM
Irelands child G'morning(evening?) Al

Looks like you have a great 'fix' installed on that fuel pump and exactly how I would have done it with the hoses. I might not have figured out the seal part though - great fix.

It amazes me how much interest there is in American cars in Australia as well as NZ.

Not too many of you Suthern guys here, but on the other and smaller site I frequent, quite a few.

OK - turbines. MW is usually written as MWe anywhere but the US. We just abbreviated it. It's mega watts or millions of watts. The left photo is of a turbine and is nominally 30MW and probably the version I had spent most of my GE career working on or inside somewhere in the world. The big one was the last significant project I worked on for 3 years+ before retiring and that's a nominal 560MW and installed in England.

The weather here isn't 'delightful' enough for any car show - unless you are an Eskimo - it's minus 19C with a wind chill of minus 29C. At least I can work on my car inside or work on a rehab of a bathroom
01-15-2012 06:06 AM
67Mustang Al.
Quote:
Originally Posted by 67Mustang Al.
Hi Dave Mw turbine.whats the "mw" for.Specialized turbine maybe???
Well that pos edelbrock fuel pump is now a "non-leaker". Yep, it was a challenge but it took a couple of hours work to fix once i sourced the seal ($4) and turned up a brass ring for a press fit.The idea of vent tubes into the engine pcv system we invented was possible by drilling the rear of the pump flange face and press fitting 5/32 brass tube from the hobby ($3.50) shop and a 6*16*7 double lip oil seal suitable for a rotary shaft application as a seal like a valve stem seal proved too difficult to source. That would be the ideal fix. The diaphragm centre shaft was turned down to remove the step and i made a brass ring to press the seal in and then press the assembly into the pump housing. Who would have thought you would do that to a new Edelbrock pump to stop it leaking.
I entered the Mustang into our annual "USA" day here in town today with Ford , Gm, Harley etc, so i checked the fuel pump about 5 times between the show and back home. Its done about 30 miles and you guessed it , not a drop of oil, even with a vent vacuum hose off for a short while
No frozen tundra here today Dave in a balmy 25 . What problems can we solve next.
P.S i changed all the cabling on the Mustang to make things tidier in the engine bay. Took me a while so if you like i can post some pics of what i changed.
Cheers.
Al
couple more pics.
01-15-2012 06:01 AM
67Mustang Al.
POS pump

Hi Dave Mw turbine.whats the "mw" for.Specialized turbine maybe???
Well that pos edelbrock fuel pump is now a "non-leaker". Yep, it was a challenge but it took a couple of hours work to fix once i sourced the seal ($4) and turned up a brass ring for a press fit.The idea of vent tubes into the engine pcv system we invented was possible by drilling the rear of the pump flange face and press fitting 5/32 brass tube from the hobby ($3.50) shop and a 6*16*7 double lip oil seal suitable for a rotary shaft application as a seal like a valve stem seal proved too difficult to source. That would be the ideal fix. The diaphragm centre shaft was turned down to remove the step and i made a brass ring to press the seal in and then press the assembly into the pump housing. Who would have thought you would do that to a new Edelbrock pump to stop it leaking.
I entered the Mustang into our annual "USA" day here in town today with Ford , Gm, Harley etc, so i checked the fuel pump about 5 times between the show and back home. Its done about 30 miles and you guessed it , not a drop of oil, even with a vent vacuum hose off for a short while
No frozen tundra here today Dave in a balmy 25 . What problems can we solve next.
P.S i changed all the cabling on the Mustang to make things tidier in the engine bay. Took me a while so if you like i can post some pics of what i changed.
Cheers.
Al
01-10-2012 06:44 AM
Irelands child Al - sounds like a 'challenge' to fix that POS more then anything else. And as far as recalls, my guess is that the user base is so small that an 'on the run' upgrade, quietly done will take care of the problem and if someone complains in the warranty period, we'll ship a new one off, but stick them with consequential damages costs. I had to play that game for several years with customers as well - sorry that your many mw turbine cratered, but loss of 3 or more months of revenue during rebuild - oh well, sorry, not my company's problem.

Off to the next - and mine is to do some battery and cable system remodeling while waiting for the normally frozen tundra of Upstate New York State to get mushy.

Dave W
01-09-2012 04:15 PM
67Mustang Al.
Quote:
Originally Posted by Irelands child
Just for the heck of it, I went on the Summit web site and looked at the current 1715 - lo and behold, no vent holes apparent in the 360* view. It almost appears that Edelbrock has handled their problem with a Carter pump rebranded (or at least used the same set of castings) http://www.summitracing.com/parts/EDL-1715/?rtype=10

I'm thinking that you could make up a pair of very small diameter tubing runs, carefully drill a couple of holes in the mounting flange or flange extension and run the pump vents back to the crankcase. Or, plug one, drill a bit bigger hole and run a single slightly larger dia. tube. After doing my playing, I then would consider replacing that POS fuel pump with the spare Carter I had ordered. But since Summit isn't a "local" supplier for you, probably not that easy without a fairly large expenditure in time and money.

You folks can keep your cyclonic weather - we had a couple of hurricane remnants, 15-20 inches of rain, this past fall which about isolated many areas locally and caused well over a billion in as yet many incomplete repairs.

Dave W
Hi Dave. Hope you have your home heat cranked up there. The cyclones here and the twisters you have there are sure sent to try us for sure. Tas has not seen a cyclone yet, touch wood. We just freeze in winter
I just copied and pasted your Summit link and yes , no vent holes. I wonder who the engineer was that failed to test that batch of POS pumps before they went to the production line. The company i used to work for that made engine bearings here , had a thorough testing and quality control program , i.e. minimimal customer aggro and product failure. There would be hundreds of oil-soaked engines out there because of this POS E pump. Some of the various blogs have guys replacing all surrounding gaskets in the area for no joy and then find the oily pump,replace flange gasket and then give up and buy a Carter. Toyota etc will put out product recalls for their mistakes, Edelbrock...............???? Cant find that on the net. Just typed in "1715 Edelbrock fuel pump recall" but surprisingly there is not a result.
Your idea for a larger tube should work Dave with one hole plugged. I was also thinking about going to the bearing and seal shop in town and trying to make a composite oil seal from two off the shelf seals glued back to back and pressed in where the original seal goes. The pump diaphragm rod reciprocates through the seal and the "boot" style Edelbrock seal goes with that motion. What a primitive idea. I have seen better seals on a house tap . I will give it a go and let you know what happens. Maybe i can come up with a fix for this pump and take Edelbrock customers away.
Double oil seal + oil tube from vent holes = fix ??????
Cheers from the deep south.
Al
01-09-2012 06:06 AM
Irelands child Just for the heck of it, I went on the Summit web site and looked at the current 1715 - lo and behold, no vent holes apparent in the 360* view. It almost appears that Edelbrock has handled their problem with a Carter pump rebranded (or at least used the same set of castings) http://www.summitracing.com/parts/EDL-1715/?rtype=10

I'm thinking that you could make up a pair of very small diameter tubing runs, carefully drill a couple of holes in the mounting flange or flange extension and run the pump vents back to the crankcase. Or, plug one, drill a bit bigger hole and run a single slightly larger dia. tube. After doing my playing, I then would consider replacing that POS fuel pump with the spare Carter I had ordered. But since Summit isn't a "local" supplier for you, probably not that easy without a fairly large expenditure in time and money.

You folks can keep your cyclonic weather - we had a couple of hurricane remnants, 15-20 inches of rain, this past fall which about isolated many areas locally and caused well over a billion in as yet many incomplete repairs.

Dave W
01-08-2012 08:58 PM
67Mustang Al. Hi Dave
We must be on the same wavelength with the tube out of the vent holes and back into the engine. Had the same thought You are correct about the differences between Carter and Edelbrock as the Edelbrock twin vent holes are to atmosphere for correct diaphragm operation.
I typed in "Edelbrock fuel pumps leaking oil" into google and there are heaps of people who have bought these early type mechanical fuel pumps only to have the same problem of oil spewing from vent holes. ( 1715 and part no;s similar.
Here is the quote i found a few minutes ago which is one of many with the same problem.

I talked to Edelbrock tech dept today. Their conclusion is I ripped/tore/messed up the diaphragm. He said I could probably use the one out of the old pump which is also a Edelbrock. So thats tonights project. Also, I originally replaced the other Edlebrock pump because it was leaking oil. I asked the guy about that and he said they will do that and the only way to fix it is to buy a new pump, it's not a serviceable seal.

So from that and others Edelbrock have made the pumps with faulty oil seals and basically bad luck you have wasted your money and like you Dave all the other oil-leaking Edelbrock fuel pump owners have gone to "Carter" pumps and thats the end of the problem according to all the blogs out there. Holley have also had similar problems.
I emailed Edelbrock but have no reply as yet.????
So i am going to beat this problem and come up with a modified oil seal from the experts in town. I have just worked on a Toyota motor of my sons and the oil seals i fitted to the timing end were all rubber coated on the outside circle to prevent oil seepage, not so with the edelbrock seal.
If you take your idea with tubes out of the vent holes one step further. What if the tubes were fed back internally into the pump behind or past the oil seal. May be onto something there Dave. The loctite 242 has slowed the gush to a trickle which proves the faulty seal.
Just another brick in the wall. Hobart recorded 140k winds this morning in prep for cold snap and high alt. snow. We are about 200k north of Hobart so it wont snow here hopefully.
Cheers to the upstater
al.
01-08-2012 07:26 PM
Irelands child Al, probably a difference in design. While the Carter may be vented back into the crankcase then to atmosphere via the pcv and dictated by the casting design, the Edelbrock may have atmospheric vents and what are spewing oil. A bit far flung, but maybe tapped holes, fit tube then run to the oil cap. An ugly fix, but you sure wouldn't lose any more oil

No wonder you are predicting snow - Hobart has almost the identical South latitude as our nearby Saratoga's North .... ~43* - and that's unpredictable weather at any time

Dave W
01-08-2012 04:16 PM
67Mustang Al.
Pump leak

Hi Dave and 66 GM.
I thought the seal or daiphragm were faulty but they were fine. The seal relies on a steel ring in the al housing pushing on a rubber boot type seal. The problem there is the very light push fit of the steel ring in the al pump housing which was never going to stop oil which is why i grabbed the loctite and drowned it. The oil spray from the under side of the hood has stopped but not completely.
After looking at this pump in pieces ,The two vent holes in the pump have to vent to atmosphere so the diaphragm can move bacwards and forwards as the cavity in the back of the pump is sealed off from the crankcase with this seal. If i plug the vent holes then the diaphragm will suck oil past the seal when pumping. I just had an idea. Maybe the vent holes are not large enough and the diaphragm is creating a partial vacuum drawing a small amount of oil in past the seal and then back out the vent holes as mist when the diaphragm moves to pump.. Clutching at straws maybe here.
P.S. Snow predicted here in a couple of days Dave in the middle of summer.???
Cheers
Al.
01-08-2012 10:14 AM
66GMC
Quote:
Originally Posted by Irelands child
Al, I'm using a Carter GM 60454 Super Strip pump instead of the Edelbrock because of prior good experience with the Carter on other cars engines. Plus, they are made by Federal-Mogul, usually a very good brand. The Edelbrocks from my discussions with folks, have a spotty reputation.

Those vent holes are not on the Carter and not sure why they are even on that pump of yours as you have full crankcase ventilation with the pcv and oil cap. Additionally, they should be in an empty chamber, for no better way to describe it, and that area should be isolated from any oil - unless there was a leak in the diaphragm or around the metal operating device. I would even consider plugging those holes and giving it a try, but only if I had another pump available.

We are having pretty decent winter weather - no snow at all and the temps generally in the 40's F(3-7C) but do expect to pay the price later. Glad my knees told me to give up skiing as the resorts are suffering. And the holidays, pretty decent, thanks.

Dave W
I've always thought those vent-holes were there, open to atmospheric pressure, in order to allow the diaphragm to flex. If there is an oil or fuel leak, I would suspect that the diaphragm is ruptured, which can lead to oil contamination.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.